Qt5.3: Could not resolve SDK path for 'macosx10.8'



  • Environment: Mac OS X 10.9 Mavericks +
    XCode 6.0 beta +
    Qt 5.3

    I tried "ls /Applications/Xcode6-Beta.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs" and only found MacOSX10.10 SDK and MacOSX10.9 SDK.
    How can I install older SDK into my Mac?



  • You may need to install previous version of Xcode
    From "What's New in Xcode":https://developer.apple.com/library/prerelease/ios/documentation/DeveloperTools/Conceptual/WhatsNewXcode/Articles/xcode_6_0.html#//apple_ref/doc/uid/TP40014509-SW1
    [quote]
    Xcode 6 Beta requires a Mac running OS X version 10.9.3 (or later) or 10.10. It includes SDKs for OS X versions 10.9 and 10.10, and iOS 8.
    [/quote]



  • You may try

    1. Open with a text editor

    Qt5.3 /5.3 /clang_64 /mkspecs /qdevice.pri

    1. change

    !host_build:QMAKE_MAC_SDK = macosx10.8

    to

    !host_build:QMAKE_MAC_SDK = macosx10.9

    1. restart your Qt


  • Hello, I had the same problem, but I just have one line in qdevice.pri, which is "GCC_MACHINE_DUMP = x86_64-apple-darwin14.0.0", I don't have "!host_build:QMAKE_MAC_SDK = macosx10.9 ", I added this line in the qdevice.pri, it stills showed "Could not resolve SDK path for 'macosx10.11'", do you have any other suggestions? Thank you very much


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    You should also post which version of Qt, OS X and Xcode you are using.



  • Hi,

    I have been the same problem and found a two way how you can fix it:

    1. Create symbol link for existing macosx folder in Xcode. This way is easy but if you will update Xcode to new version you will need recreate symbol link.
    2. I think it's best way. Open your application folder and remove all files with '.user'. This will remove project settings and you will need reconfigure your project. When you will open your project QtCreator will ask you about new kits. Select kits which you need and click Ok. After this try build you project. All must works.

    WARNING: If you have some custom scripts for you build step in project settings and you select second way you lost this settings. Please save all configuration before you remove settings.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.