[SOLVED] Qt kit version problems with MinGW



  • I have practically a clean installation of Windows 8.1.

    I downloaded this file: http://download.qt-project.org/official_releases/qt/5.3/5.3.0/qt-opensource-windows-x86-mingw482_opengl-5.3.0.exe

    I Installed it with all the options. I also tried the online installer, same results. Here is the problem:

    When I try to create a new project or open an existing one, Qt Creator informs me that "No valid kits found."

    When I go to the Build & Run options and select Qt Versions, there is one Auto-detected "Qt 5.3.0 MinGW 32bit" which has an error icon next to it. It also says "qmake does not exist or is not executable". The path however is correct and there is a qmake.exe there.

    If I remove the automatically added item and add qmake manually, it gives me an error: "The qmake executable C:\Qt\Qt5.3.0\Qt\mingw482_32\bin\qmake.exe could not be added:".

    From the command line I can see that the qmake.exe works just fine:

    @
    C:> qmake -v
    QMake version 3.0
    Using Qt version 5.3.0 in C:/Qt/Qt5.3.0/5.3/mingw482_32/lib
    @

    @
    C:>qmake -query
    QT_SYSROOT:
    QT_INSTALL_PREFIX:C:/Qt/Qt5.3.0/5.3/mingw482_32
    QT_INSTALL_ARCHDATA:C:/Qt/Qt5.3.0/5.3/mingw482_32
    QT_INSTALL_DATA:C:/Qt/Qt5.3.0/5.3/mingw482_32
    QT_INSTALL_DOCS:C:/Qt/Qt5.3.0/Docs/Qt-5.3
    QT_INSTALL_HEADERS:C:/Qt/Qt5.3.0/5.3/mingw482_32/include
    QT_INSTALL_LIBS:C:/Qt/Qt5.3.0/5.3/mingw482_32/lib
    QT_INSTALL_LIBEXECS:C:/Qt/Qt5.3.0/5.3/mingw482_32/bin
    QT_INSTALL_BINS:C:/Qt/Qt5.3.0/5.3/mingw482_32/bin
    QT_INSTALL_TESTS:C:/Qt/Qt5.3.0/5.3/mingw482_32/tests
    QT_INSTALL_PLUGINS:C:/Qt/Qt5.3.0/5.3/mingw482_32/plugins
    QT_INSTALL_IMPORTS:C:/Qt/Qt5.3.0/5.3/mingw482_32/imports
    QT_INSTALL_QML:C:/Qt/Qt5.3.0/5.3/mingw482_32/qml
    QT_INSTALL_TRANSLATIONS:C:/Qt/Qt5.3.0/5.3/mingw482_32/translations
    QT_INSTALL_CONFIGURATION:
    QT_INSTALL_EXAMPLES:C:/Qt/Qt5.3.0/Examples/Qt-5.3
    QT_INSTALL_DEMOS:C:/Qt/Qt5.3.0/Examples/Qt-5.3
    QT_HOST_PREFIX:C:/Qt/Qt5.3.0/5.3/mingw482_32
    QT_HOST_DATA:C:/Qt/Qt5.3.0/5.3/mingw482_32
    QT_HOST_BINS:C:/Qt/Qt5.3.0/5.3/mingw482_32/bin
    QT_HOST_LIBS:C:/Qt/Qt5.3.0/5.3/mingw482_32/lib
    QMAKE_SPEC:win32-g++
    QMAKE_XSPEC:win32-g++
    QMAKE_VERSION:3.0
    QT_VERSION:5.3.0
    @



  • Well, after successfully installing the Qt to another Windows 8.1 machine I copied the "C:\Qt" and "C:\Users<USER>\AppData\Local\Roacming\QtProject " folders to the machine where it didn't work. But still qmake did not work.

    So, I knew that the only thing different on those two machines was the "COMODO Internet Security". After uninstalling that junk (disabling didn't seem to help), qmake is now working properly and I can actually use Qt Creator.

    This was another reminder why I switched to linux on my main comp years ago. Hopefully this message will help anyone in the future: turn off your anti-virus or if that doesn't help, uninstall it. I wish the Comodo could have at least informed me that it had blocked the software...


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.