Please nominate your Qt Champions for 2021!

[Solved] Cannot run qt application even copying plugins folder into the executable folder?

  • Seems there was no available platforms, but I don't know why
    since I've copied all the dlls over already.
    I ran dependx64.exe, even there were no problems at all.
    Any ideas?

    Module: 5.1.0
    File: Kernel\qguiapplication.cpp
    Line: 790

    Failed to Load platform plugin "windows". Available platforms are:

  • Moderators

    You shouldn't copy the whole plugins folder. It won't work. Copy only the relevant files from the subfolders. Please refer to the "deployment guide": to put everything in the right place.

    In your case this message means you've misplaced or didn't copy over the platform plugin.
    Copy <Qt dir>\plugins\platforms\qwindows.dll to
    <your app dir>\platforms\qwindows.dll
    Notice no extra "plugins" folder in the target directory.

  • Oh yes, thanks, it works now

  • can you add [SOLVED] to the title in order for other to know that is done and will also help others that are looking for solutions

Log in to reply