[SOLVED] Unknown module in Qt: enginio



  • Hi guys,

    I recently installed qt using the online installer. After installation I used the Maintenance Tool to install QtCloudServices (which I forgot during the initial installation). I can see the files in the Qt map under Cloudservices but after loading the cloudaddressbook example project I cannot build the project because of this error;

    Unknown module in Qt: enginio

    I am not sure how to proceed and I am really looking forward on using this module so... help!? BTW, I am using Windows 8.1, Qt5.3.0, msvc2013 64 bit OpenGL, Qt Enginio 1.0.

    Thanks in advance!
    Rob



  • You could try installing the module - in a Qt command line, type:
    qmake && nmake install



  • Thanks.. you put me on the right track. It was even easier.. just find the qtenginio.pro file, open this and build it in QtCreator (or build it using the command line), this creates the libraries and finally import these libraries into your own project.

    BTW, I added this to my project file to use the libs:

    @unix|win32: LIBS += -lEnginio
    unix|win32: LIBS += -lEnginiod@



  • FYI, I've tried to reproduce your problem (install on Windows 7, MSVC without QtCloudServices, then adding QtCloudServices with the maintenance tool), but it worked out-of-the-box.



  • Strange.. guess it's a Win8 or my computer specific problem then.

    Thx for your help!



  • Strange that you were able to add the library through the maintenance tool. Enginio should be installed together with other addons, there should be no special QtCloudServices option starting from Qt5.3. I will try to reproduce it. From your message I understand that you have a clean installation based on the Qt5.3.0 online installer, is that correct?



  • @Nierob

    On my current PC this was the first installation of Qt5.3. I installed Qt using the online installer with these options,

    !http://breinbaas.nl/img/Knipsel.JPG(installation options)!

    (BTW, I did NOT check the QtCloudServices option the first time so the screenshot isn't quite correct)

    Later I used the maintenance tools to install QtCloudServices and the source of Enginio.

    In both cases when I opened QtCreator and tried to build the Enginio examples I got the `Unknown module in Qt: enginio' error.

    After building it myself and including it in (my own) project it was ok.

    Hope this helps!

    Best regards,
    Rob



  • Ok, I tried to reproduce the problem (on linux) and I failed maybe it is platform dependent I will try to find a windows machine.

    You can try to install Qt5.3.1 which is released today. Enginio is included by default, Qt Cloud Services do not need to be checked.



  • Great, I will check it out, thank you!

    BTW, it is a very nice module, I got it working (off course with still a lot of questions) and now my project data is available in the cloud which is a major step for my software project so thanks a lot to all Qt developers!

    For those interested in my code; it is available at https://github.com/breinbaas/bbsuite

    and here is a small screenshot of the current state;

    !http://www.breinbaas.nl/img/boreholeeditor.jpg(My QtApp)!


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.