Qt 5.2.1/5.3 Android debug doesn't work?

  • I am working on QtQuick 2.2 application. Debug works excellent on Desktop(Win/OSX) and iOS platforms. But when i try to "Debug" application on Android (real device or simulator) - debug doesn't start (but application trying to start). When i try "Run" (on real device or simulator) - no have any problem.

    I am tried to "Debug" different Qt-exmples (Colliding Mice, Maroon in Trouble, and many others), and have similar problems.

    Steps to reproduce problem:

    1. Open any Qt/QtQuick project in QtCreator
    2. Select building and deployment to Android device
    3. "Build" - "Run" from Qt-Creator menu. Application compiles, installed to device, started, and working fine
    4. "Debug" - "Start debug" from menu. Application compiles, installed to device, started, and... not respond some time, then crushed.

    Did anyone has similar problems?

  • Yes, I have the same problem with any simple Qt Widget application and Qt 5.2, 5.2.1.
    With Qt 5.3, the application start on the phone (or emulator) but Qt says that startup failed.
    I am running Qt on Ubuntu 14.04.

  • how about your problem? did you resolve it?

  • No, I have still no solution. SInce I encountered some more serious issues, I decided to use the Java SDK until Qt comes to a useable state. It's a bit frustrating.

  • Lifetime Qt Champion


    Which version of android sdk/ndk are you using ?

  • If anyone had any success with Qt and Android? If so please reply. I could use some encouragement.

    I have burned over a week of work failing to get a :hello world" Qt5.3.* or Qt5.2.* widget application to run on Android. iOS is no problem.

    I have setup a number of development VMs using both Ubuntu 14.04 both 32-bit and 64-bit hosts, OS X hosts, NDX r8 and NDK r10. I have tried both Qt 5.2.1 and Qt 5.3.1 without success. I am using the latest adt-bundle-linux-x86-20140702 and NDK r10 currently.

    I have gotten furthest with OS X were the simulator started launching before data exception occurred:

    I am currently on Ubuntu 14.04 32-bit stuck here:
    /home/edward/Qt5.2.1/5.2.1/android_armv7/bin/uic ../qt-hello-world/mainwindow.ui -o ui_mainwindow.h
    /home/edward/android/android-ndk-r10/toolchains/arm-linux-androideabi-4.8/prebuilt/linux-x86/bin/arm-linux-androideabi-g++ -c -pipe -std=gnu++0x -g -g -gdwarf-2 -marm -O0 -fno-omit-frame-pointer -Wall -Wno-psabi -W -D_REENTRANT -fPIE -DQT_QML_DEBUG -DQT_DECLARATIVE_DEBUG -DQT_WIDGETS_LIB -DQT_GUI_LIB -DQT_CORE_LIB -I../../Qt5.2.1/5.2.1/android_armv7/mkspecs/android-g++ -I../qt-hello-world -I../../Qt5.2.1/5.2.1/android_armv7/include -I../../Qt5.2.1/5.2.1/android_armv7/include/QtWidgets -I../../Qt5.2.1/5.2.1/android_armv7/include/QtGui -I../../Qt5.2.1/5.2.1/android_armv7/include/QtCore -I. -I. -I../../android/android-ndk-r10/sources/cxx-stl/gnu-libstdc++/4.8/include -I/home/edward/android/android-ndk-r10/sources/cxx-stl/gnu-libstdc++/4.8/libs/default/armeabi-v7a/include -I../../android/android-ndk-r10/platforms/android-19/arch-arm/usr/include -I. -o main.o ../qt-hello-world/main.cpp
    In file included from ../../android/android-ndk-r10/sources/cxx-stl/gnu-libstdc++/4.8/include/algorithm:60:0,
    from ../../Qt5.2.1/5.2.1/android_armv7/include/QtCore/qglobal.h:82,
    from ../../Qt5.2.1/5.2.1/android_armv7/include/QtGui/qwindowdefs.h:45,
    from ../../Qt5.2.1/5.2.1/android_armv7/include/QtWidgets/qwidget.h:45,
    from ../../Qt5.2.1/5.2.1/android_armv7/include/QtWidgets/qmainwindow.h:45,
    from ../../Qt5.2.1/5.2.1/android_armv7/include/QtWidgets/QMainWindow:1,
    from ../qt-hello-world/mainwindow.h:4,
    from ../qt-hello-world/main.cpp:1:
    ../../android/android-ndk-r10/sources/cxx-stl/gnu-libstdc++/4.8/include/utility:68:28: fatal error: bits/c++config.h: No such file or directory
    #include <bits/c++config.h>

  • SDK 22.6.2
    NDK r9d
    Oracle JDK 1.7.0_55
    Ubuntu 14.04
    Qt 5.3

    However, I tried it with several older versions of each component and had the same issue on all of my 3 different Android devices.

    @EdOfTheMountain: Please open a separate thread for your issue. We are talking here about the debugger not working (while everything else works fine).

  • I'm in the same boat. I'm using Qt 5.3. I have tried NDK r8e and r10 to no avail. I'm running on Mac OS X 10.8.

  • I upgraded to Qt 5.3.1 and NDK release 10. The debugger works fine now on my devices.

  • [quote author="s.frings74" date="1410805900"]I upgraded to Qt 5.3.1 and NDK release 10. The debugger works fine now on my devices.[/quote]
    Show screnshot of Qt Creaor setups, please.

  • I don't know how to upload screenshots. The problem disappeared after upgrading stuff, the settings are still the same.

    JDK path: /usr/lib/jvm/java-7-openjdk-i386
    Android SDK: /opt/adt-bundle/sdk
    Android NDK: /opt/adt-bundle/android-ndk-r10

    Ant: /usr/bin/ant
    The AVD-Manager block is empty.

    Qt is installed in /opt/qt

Log in to reply