Cannot run qt designer, assistant, ect.



  • I downloaded Qt SDK for my windowsXP. At first, everything was ok, qt designer.exe, assistant.exe, ect. runs perfectly. However, after a while looking around and do somethings with Qt, a strange problem appeared and every executable file in Qt/qt/bin, including designer.exe, assistant.exe, ect. cannot run. The same error message always occurs:

    " ... - Entry Point Not Found
    The procedure entry point ... could not be located in the dynamic link library QtCore4.dll"

    QtCore4.dll is still there, I didn't delete anything in that folder. I cannot understand why.

    I tried copying the executable files to Qt/bin but nothing different.

    Please help me, thank you very much in advance.



  • Uninstall and reinstall

    May be of some files got corrupted..

    Repairing only solution I feel :)



  • "Entry not found" these happens when the dll is not properly built or instead of new dll its referring to some old dll which is not having the connecting method call.

    While u can always try to re install mine suggestion is u can rebuild the qt using setup file and Readme .

    Also you can check ur environment variables to be pointing to correct dlls.



  • Thanks, I reinstalled it, and no problem now.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.