[SOLVED / missing feature] Qt Creator - control which Qt version Help (F1) works for



  • Hi everyone,

    My system has both Qt 4.8.3 and Qt 5.2.0, working with Qt Creator 3.0.0. When I click on F1 on parts of my code (for example some usage of QLabel) I get context help but it is displayed for version 4.8.3. This isn't so comfortable since most of my development is with Qt 5.2.0.

    I found that with the Tools->Options->Help window I can actually Remove the 4.8.3 items from the "Registered Documentation" list. This solves the problem for the duration of the session. But when I restart Qt Creator these items reappear, probably as the different available Qt Versions are loaded.

    Is there any way to set which version is preferred and have that setting last longer than a session?


  • Lifetime Qt Champion

    Hi,

    Sounds like it might be a missing feature (I haven't found anything for that use case) One thing that would be interesting is to have the help content tied to the current Qt used.

    You should go to the "bug report system":http://bugreports.qt-project.org and check it this is something that has already been asked if not, please consider opening a feature request


  • Moderators

    It's a missing feature. Please add your comments to https://bugreports.qt-project.org/browse/QTCREATORBUG-11039



  • Thank you very much for pointing me there, I added a comment and a vote.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.