[SOLVED] Qt 4.8.6 can't deploy on OSX



  • Hello,
    I've been successfully deploying with Qt 4.8.5 several times and now that I switched to Qt 4.8.6 I can't anymore.
    It seems the system paths of where the Qt libraries are installed, are ignored, and instead the "otool -L" command on my binaries shows "/usr/local/Trolltech/Qt-4.8.6/lib/Qt..." which doesn't even exist.
    It seems the only place where it is defined is:
    qconfig.pri:QMAKE_RPATHDIR += "/usr/local/Trolltech/Qt-4.8.6/lib"
    in /usr/local/Qt4.8/mkspecs

    So my nametool instructions fails to detect the right paths (which should be /Library/Frameworks/Qt*.framework) and the resulting bundle is corrupted, or works only if Qt is installed in the system.

    I uninstalled Qt 4.8.5 using the uninstall-qt.py tool and then I've installed Qt 4.8.6.
    Did I miss something ?
    Does anyone have a suggestion about this ?

    Thanks



  • I uninstalled 4.8.6 and reinstalled 4.8.5.
    The qconfig.pri doesn't even have a QMAKE_RPATHDIR variable.

    I also double checked the 4.8.6 release notes and this change is not mentioned.
    Maybe it was worth a word since it dramatically changes things when deploying ?

    I also tried to comment the guilty line from qconfig.pri in Qt 4.8.6 but the result is the same.
    It seems that path is hardcoded in the libraries !

    ...this is driving me crazy


  • Lifetime Qt Champion

    Hi,

    Sounds strange indeed, you should bring that topic to the interest mailing list. You'll find there Qt's developers/maintainers (this forum is more user orientated)



  • The release has been re-packaged after my ticket.
    It's now named 4.8.6-1

    http://download.qt-project.org/official_releases/qt/4.8/4.8.6/qt-opensource-mac-4.8.6-1.dmg


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.