Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

[Solved] Cant get libraries to compile when modified without double compile



  • I have a project that has a main application and two libraries. I have a top level workspace that configures everything into a single project subdirs template.

    I can make modifications in the application and it compiles as expected. My trouble is in the libraries. When I make a modification in a library, I have to either compile it twice or rebuild all. Its as though the libraries are one compile behind. Not sure how to fix this.

    Here's the top level workspace subdirs .pro file:

    @cache()

    TEMPLATE = subdirs

    SUBDIRS += ../Underworld ../Horus ../Lotus

    Underworld.subdirs = Underworld
    Horus.subdirs = Horus

    Horus.depends = Underworld
    Lotus.depends = Underworld
    Lotus.depends = Horus
    @



  • Ok, here's what fixed it...

    @
    cache()

    TEMPLATE = subdirs
    CONFIG += ordered <--this was what I needed

    SUBDIRS = ../Underworld ../Horus ../Lotus

    @


Log in to reply