Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

[RESOLU] Installation from sources



  • Hi,

    I want install Qt 5.2.2 from sources on my Linux.
    I run "./configure" & "make" command and here is the result :

    @...
    ...
    Running configuration tests...
    The test for linking against libxcb and support libraries failed!
    You might need to install dependency packages, or pass -qt-xcb.
    See src/plugins/platforms/xcb/README.
    [charlie@VmManjaro qt-everywhere-opensource-src-5.2.1]$ make
    make: *** Pas de cible spécifiée et aucun makefile n a été trouvé. Arrêt.
    [charlie@VmManjaro qt-everywhere-opensource-src-5.2.1]$
    @

    I must install a static version in the specific folder. So I run this command :
    @./configure -prefix /home/dev/qt -static@

    I test with this command :
    @./configure -prefix /home/dev/qt -static -qt-xcb@

    but the result of make command is the same.

    Note : libxcb is installed

    Have you an idea to resolve my problem

    In advance thank you



  • Do you have all dependencies satisfied as it is described in "Building Qt 5 from Git":http://qt-project.org/wiki/Building_Qt_5_from_Git ?



  • Hi,

    Indeed, some libraries were missing. I corrected this and here is the new error message:

    @WARNING: Using static linking will disable the use of dynamically
    loaded plugins. Make sure to import all needed static plugins,
    or compile needed modules into the library.

    Could not find qmake configuration file linux-g++.
    Error processing project file: /home/charlie/Téléchargements/qt-everywhere-opensource-src-5.2.1/qt.pro

    Qt is now configured for building. Just run 'make'.
    Once everything is built, you must run 'make install'.
    Qt will be installed into /home/dev/qt

    Prior to reconfiguration, make sure you remove any leftovers from
    the previous build.

    [charlie@vmManja qt-everywhere-opensource-src-5.2.1]$ make
    make: *** Pas de cible spécifiée et aucun makefile n'a été trouvé. Arrêt.
    [charlie@vmManja qt-everywhere-opensource-src-5.2.1]$@


  • Lifetime Qt Champion

    Hi,

    What are the configure options you used ?



  • Hello,

    I use this command :
    @./configure -prefix /home/dev/qt -static@

    I have already installed qt like this on a 64 bit machine (Manjaro KDE).
    Here I try to do it on a 32 bit virtual machine (Manjaro KDE).


  • Lifetime Qt Champion

    Did you cleaned up before calling configure again ?



  • Yes, if finally delete all files and start over from the beginning enough ;)


  • Lifetime Qt Champion

    So did your build succeed ?



  • unfortunately not


  • Lifetime Qt Champion

    same error ?



  • Hello,

    Yes, same error.

    Charlie


  • Lifetime Qt Champion

    Try the following: uncompress your sources in a path without special char like é (e.g. /home/charlie/Qt/) and restart the configuration process



  • well, well, well ...

    My problem came well there.
    On my host I have taken care to translate all my files in English, but not on the guest ... :(.... rrrr "the French touch" ;)

    Thank you very much for your help.


  • Lifetime Qt Champion

    Also sounds like there's a bug somewhere if the script fails for because there's an é in the path

    You're welcome !

    Now that you have it working, please update the thread title prepending [solved] so other forum users may know a solution has been found :)


Log in to reply