[solved] Qt Cross-Compiling configuration for Rpi Application



  • HI guys,

    I have got Qt5 installed using the qt.run file, which I had downloaded from the Qt Project website (Qt was installed properly and I can work on my desktop), on my Ubuntu 12.04. I've followed this "guide":http://qt-project.org/wiki/RaspberryPi_Beginners_guide to be able to cross-compile my apps. What I'm able to do is to configure the Qt Version for the Rpi. I can't configure my Qt Creator, because I don't know where the qmake for rpi is installed even thouhgt I have installed the linario gcc. What am I missing? Is it mandatory that I must to compile qt5 from the source files? Where can I get the qmake files for rpi?

    Moreover I have read these documents:

    "document_1":http://www.ics.com/blog/building-qt-5-raspberry-pi#.U0P-BY8vnCJ --> I can't mount the Raspbian SD image file on the Desktop PC as described on the document, using the command $sudo mount -o loop,offset=62914560
    raspberry-working-image.img /mnt/raspberry-rootfs

    "document_2":http://www.ics.com/blog/building-qt-and-qtwayland-raspberry-pi#.U0QIIo8vnCJ
    the same problem, I was unable to mount the rpi by the remote command sudo mount x.x.x.x:/ /mnt/rpi-rootfs but I think this is due to the fact I'm not using the NTFS file system and I don't have sharing folder.

    Furthermore, I have read a lot of documentation about how to set a toolchain to be able to build application for rpi using Qt5. Nothing has work well, there where everytime something that doesn't do what expected.

    Now I need a big help...

    Thank you in advance.



  • OK, this is just to close this topic.
    I have solved the problem alone. I have followed this "guide":http://www.ics.com/blog/building-qt-5-raspberry-pi#.U0ubso_7sYy from the beginning to the end and everything has started working well.

    Thank you anyway to all the guys which have read this topic.


  • Moderators

    Hi,

    Thanks for the link. I didn't see that one yet,

    Could you please add [closed] in the title of your post. This will show in the overview there is already a solution



  • [quote author="Eddy" date="1397469932"]
    Could you please add [closed] in the title of your post. This will show in the overview there is already a solution[/quote]

    Yes off course... excuse my ignorance but, how can I do that? I have already tried to check the close flag on the main post and also on the solution post but it doesn't close (checking "solved") the topic; and I can't modify the title! So how can I close the topic?


  • Moderators

    Hi,

    You should be able to edit your first post of this thread (edit link under the text you entered), then go to the title and add [solved]

    Do you see the edit link?



  • Yes, I did it.
    Thanks.


  • Moderators

    good deal.

    Have fun with the Pi!!


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.