Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Is it possible to run remotely an executable built with CMake ?



  • Hello,

    I am currently trying to run an executable built with Cmake on a remote device.

    I followed the tutorial to set up a kit and use a toolchain. To test, I used a QtCreator project and everything works perfectly (I can build the project, deploy it on the device and execute it remotely).
    However I cannot do the same for a CMake project. I can build it and deploy it but I cannot run it. In fact, when I go to projects->name_of_my_kit->Run, I do not have the same options in the Run part.
    With a QtCreator project there are two fields which show the path toward my local and remote executables whereas now I can only chose one executable and it is the local one.

    I have spent a lot of time to google my problem and I have not found yet someone trying the same thing.

    Is it possible to run an executable built with CMake remotely through QtCreator ?
    My last goal is to debug while the programme is running on the device like a QtCreator project.

    QtCreator : 3.0.1
    Ubuntu 12.04
    Qt : 5.2.1


  • Moderators

    How to deploy files to devices (and which files need to be deployed) is unfortunately bound to the build system used. Creator does not support that for cmake at this time.

    You can add the necessary steps manually (e.g. by running scp as a custom step in the deployment) and then run a custom executable which will run your command via ssh on the target machine. That is a bit of work to set up though.



  • @moutie Hi This is M.Ijaz from Pakistan, I am working on qt application to run remotely. I tried much time but not successful yet. will you please help me.?



  • I want to run my qt application which I design in Host PC to the sdr board.


  • Lifetime Qt Champion



  • @aha_1980 Hi, thanks for reply,
    I have successfully deployed project to sdr boad.
    I have cross compiled executable file from QT 4.8.7 and i am running it on SDR ADRV9361 board (Linaro-Ubuntu). When i run the cross compiled executable file (which is cross compiled on Ubuntu 16.04) on my SDR board, i got the error message like : " symbol lookup error : ./project: undefined symbol: _ZN7QWidget8qwsEventEP8QWSEvent". I don't know why i am getting this error as I conformed tool chain version on both side, please help.

    I followed following forums:

    https://mechatronicsblog.com/cross-compile-and-deploy-qt-5-12-for-raspberry-pi/

    https://forum.qt.io/topic/52546/tuto-build-qt-to-cross-compile-for-arm/2

    https://www.tal.org/tutorials/building-qt-512-raspberry-pi

    I have deployed my qt project to my sdr board. When I try to execute my project on board following error occurs:

    symbol lookup error: ./project: undfined symbol: _ZN7QWidget8qwsEventEP8QWSEvent

    I have verified following from PC and Board outputs are given bellow respectively:

    strings /usr/lib/arm-linux-gnueabihf/libQtDeclarative.so.4 | egrep 'qwsEvent|x11Event'

    PC:
    _ZN7QWidget8qwsEventEP8QWSEvent

    Board:
    _ZN7QWidget8x11EventEP8QWSEvent

    Now only difference is qws and x11, How I can change this x11Event (Board) to qwsEvent to execute my project successfully?


  • Lifetime Qt Champion

    Hi @Mijaz ,

    Please don't necro-post threads with a question that is not even related to the original author's problem.

    As for yours, you need to deploy your cross-compiled Qt on your board so its found rather than your board provided version.



  • Hi @SGaist ,
    Thanks for responding, I have deployed my cross-compiled Qt to the board, But I am unable to find the reseason why the classes are changed (qwsEvent | x11Event).


  • Lifetime Qt Champion

    Let's continue there.


Log in to reply