Nominate our 2022 Qt Champions!

[Solved]Slow or not working Auto Completion in QtCreator 3.0.1 running on linux-mint (64bit) Cinnamon

  • Hi,
    I used to install and work with QtCreator in my Linux Cinnamon environment,
    When I installed the latest version I realised the editor auto-completion is not responding to ctrl+space that I used to work with flawlessly.
    I am wondering why when I complete the statement until (.) and (-->) it does not work but after inserting (.) or (-->) it works.

    Is it something wrong with implemented library/function parsing !?
    Note: This lag not responding mainly happens when I types ClassNames not that much for methods or variables

    Even when I start to write something in new line and the pressing CTRL+SPC in the middle of typing to trigger code autocompletion it seems for a number of seconds the editor become unresponsive (I can not insert more characters and backspace does not work either) .

    What has happened to the editor so it became so slow
    Is it something with Cinnamon,Graphic renderer or slow code parsing !?
    Please note that Linux Mint system is running under VMWare Fusion 6.0.2(Mac) and vmware-tools are already installed in my guest machine.

    For more information the editor's option autocompletion is as follows:

    and DoxyGen panel items are all enabled.

    Thanks in advance.

  • The same problems here on a 'normal' Win8 PC. It was solved when I set the autocompletion to manual or when triggered.
    The auto completion was to blame if you ask me. Especially with lots of files open or huge files be edited.

  • I made a workaround (I have no clue what have happened in background) but it seems that worked for me.

    You might try it on your own risk,
    I closed the project in QtCreator, then I closed the QtCreator application.
    Then I modified my project directory and I have deleted all the files that they ended with *.pro.user (OBS: do not delete your [main project file]).
    Then I deleted all the files and directories for build version.
    Once I opened a project again in QtCreator , the IDE asked that the user setting are not present I need to redefine and modify the project again.

    After modification completion and saving the user settings the Qt Creator code completion worked again like a charm.

  • Hi,
    Just turning the autocomplete off and rebuild/clean the project and then setting to automatic did the trick for me.
    ***If the post is solved, please place [SOLVED] before your first post! ***

Log in to reply