QT5 can't run .exe without QT - Win8.1



  • Hi,

    I read nearly all posts about this problem but i still didn't found any solution.
    When i'm running my QTProject .exe outside of Qt , i get " 10000000" .dll missing errors.
    After inserting the normal QT.dll's "10000000" procedure entry errors appear.

    I used dependency walker to check my exe and there it says it misses many API-MS-xxxxxx files.

    Is there any solution to make it just work, without any errors?.......



  • Hi, if you start your app from a CMD window, i.e.
    start a CMD, first run the qtenv2.bat file in Qt's bin directory (to setup a path to Qt's dlls), cd to your apps' build directory and then run your app, what errors are shown?



  • hmm, in cmd it works without any errors,
    but using the Windows Explorer and click on .exe doesn't work.

    i don't understand it.......



  • i also tried to run my app as admin in the explorer, now it works.
    why do i need the admin rights for a simple .exe?



  • Is it an empty project or did you add some code? If so, mabye you're writing a file in C:\ or trying to print/read the whole screen, or something else that Win8.1 restricts access to.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.