Important: Please read the Qt Code of Conduct -

QML SoundEffect Unreliable

  • Hi,
    I am developing with Qt 5.2.1 on an Android 4.4 device.
    Firstly I am not sure if this is a QtQuick or an Android related issue and if this is posted in the wrong place please advise.
    I am trying to use several SoundEffects in my application to give audio response upon button press.
    While I am able to trigger the audio clips when a button is pressed, on occasion the sound will stop playing and further button presses will not cause the clip to play again.
    Looking at the component properties during run time they change as if the sound is still playing and report no errors but no audiable output is generated. However other SoundEfffects still work as expected.
    I have found that if I change the SoundEffect source file dynamically once it has "broken" the new sound will play as the buttons are pressed, but again after some time the sound will fail to play.
    It seems that rapid button presses can cause the situation to occur more frequently.

    If anyone has encountered a simmilar issue and can offer some help that would be great.

  • I have the same issue with SoundEffect and Qt 5.3. Sometimes it just doesn't play sound without any errors.

    For me it happens on android device when screen is off and SoundEffect is triggered after 30 seconds. (PARTIAL_WAKE_LOCK is handled and other sounds works). If it is triggered after 20 secs, all sounds are ok.

  • Looks like it happens only to sounds with less than a second length.
    In my case "beeps" don't work, other sounds play nicely.

    So for "beeps" I reassign source (source = ""; source = "/sounds/beep" and it works.

    Ugly but nevertheless.

  • Lifetime Qt Champion


    That might be something to talk about on the interest mailing list. You'll find Qt's developers/maintainers there (this forum is more user oriented)

  • [quote author="SGaist" date="1406753140"]Hi,

    That might be something to talk about on the interest mailing list. You'll find Qt's developers/maintainers there (this forum is more user oriented)[/quote]

    I have tried to find issue tracker first on digia, but had no luck.
    What mailing list would you suggest?

  • Lifetime Qt Champion

    The bug tracker is "here":

    Interest is the name of the mailing list (I know, might be confusing :))

  • Topic is old but the bug is still alive.
    I use QtMultimedia 5.7 and sound stop working after >10x button clicked. Then randomly goes back.

            id: cellSoundId
            source: "Sound/yourMove.wav"

    I have tried using either Audio object or .mp3 file but exactly the same.

    Does anybody solved the issue?

  • Me too found this annoyng problem. It happen in Android only, smae code on Windows work well. Did you find a workaround?

    Error returned by Android is the following:

    E AudioTrack: AudioFlinger could not create track, status: -12
    E libOpenSLES: AudioTrack::initCheck status 4294967284
    W libOpenSLES: Leaving Object::Realize (SL_RESULT_CONTENT_UNSUPPORTED)

    error -12 mean "out of memory"

  • QT5.14.0-release on Ubuntu18.04 the same result. This bug still exists and is not fixed!

  • Sept 2020 and same bug still remains. I noticed that if another audio file is playing (eg: background music) then soundeffect plays fine. Otherwise, no audio from sound effect.

    I tried the workaround of settings source to "" and back, but that didn't work.

Log in to reply