Qt4 phonon on mac osx: phonon backend plugin could not be loaded



  • I compiled the latest static version of 4.8.6 on my OSX 10.8. Everything is fine, except the phonon part. Whenever I try running my app, the warning "phonon backend plugin could not be loaded" always emerges, and the video cannot be played.
    I tried either copying phonon backend to plugin folder into my app buldle or running macdeployqt, but no success.

    Any one have a solution to this? Thank you very much.



  • I've built the shared/framework version of Qt and phonon without no problem. Still stuck with static build.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.