Congratulations to our 2022 Qt Champions!

Is Qt5 supported in CentOS 5.3? Which Linux distro is supported?

  • I was using CentOS 5.3.

    I got error GLIBC_2.10 , GLIBC_2.11, GLIBC_2.7, GLIBC_2.9 not found.
    I tried to install the latest version of gcc-4.8.2 already, but still encounter such error.

    Anyone can suggest the minimum distro that is supported with Qt5?

    Many thanks.

  • Any modern distro will support Qt 5.
    CentOS is a little bit outdated.

  • Thanks andreyc.

    How about the latest version of CentOS? I would like to know if anyone successfully installed Qt5 in CentOS6.5.

  • Moderators

    Hi kshul,

    I don't have CentOS experience myself, but you might find these posts useful:

  • bq. CentOS is a little bit outdated.

    In my previous post I meant that CenOS 5.3 is outdated. Not all CentOS.

    "Distrowatch": shows that CenOS 6.5 uses glibc 2.12 which is good enough for Qt5.

  • I tried to install in CentOS 6.5 now.

    I can install Qt creator by simply, but encountered the error when qtcreator is started.

    Failed to load core: /opt/Qt5.2.1/Tools/QtCreator/lib/qtcreator/plugins/QtProject/ Cannot load library /opt/Qt5.2.1/Tools/QtCreator/lib/qtcreator/plugins/QtProject/ (/usr/lib/ version `GLIBCXX_3.4.15' not found (required by /opt/Qt5.2.1/Tools/QtCreator/lib/qtcreator/plugins/QtProject/../.././

    Then I update the GCC by the following steps
    tar xzf gcc-4.8.2.tar.gz
    cd gcc-4.8.2
    cd ..
    mkdir objdir
    cd objdir
    $PWD/../gcc-4.6.2/configure --prefix=$HOME/gcc-4.6.2

    However, got the error during make as follows:

    [ -f stage_final ] || echo stage3 > stage_final
    make[1]: Entering directory /root/Downloads/objdir' make[2]: Entering directory/root/Downloads/objdir'
    make[3]: Entering directory /root/Downloads/objdir' rm -f stage_current make[3]: Leaving directory/root/Downloads/objdir'
    make[2]: Leaving directory /root/Downloads/objdir' make[2]: Entering directory/root/Downloads/objdir'
    Configuring stage 1 in ./gmp
    configure: error: invalid variable name: --enable-languages
    make[2]: *** [configure-stage1-gmp] Error 1
    make[2]: Leaving directory /root/Downloads/objdir' make[1]: *** [stage1-bubble] Error 2 make[1]: Leaving directory/root/Downloads/objdir'
    make: *** [all] Error 2

    Have I missed out any steps?

  • @
    tar xzf gcc-4.8.2.tar.gz
    $PWD/../gcc-4.6.2/configure --prefix=$HOME/gcc-4.6.2

    Is it a typo in your post or you tried to build wrong version of gcc?

    I think I underestimate CentOS. I did not use it but wrongfully assumed it should not be a big problem to install Qt5 on the latest CentOS.

    Take a look on this "howto":
    Maybe it will help.

  • Yes. It was a typo. I am using gcc-4.8.2.

    Thank you for the advice.

Log in to reply