QNetworkConfigurationManager doesn't work in Symbian^3 with Qt 4.7.1!!



  • I have installed Qt 4.7.1 and Qt Mobility 1.1.0 in my N8.

    @
    QNetworkConfigurationManager manager;
    QList<QNetworkConfiguration> allConfigs = manager.allConfigurations();
    @

    allConfigs is always empty.

    I installed Bearer Example that comes with Qt Moblity 1.1.0. But, connection list is blank.

    Also tested with C7, and connection list were blank again.

    I installed the same example in 5th Edition phones (5800 XP and 5230), and all works as expected.

    Where is the problem?

    [EDIT: code formatting, please use @-tags, Volker]



  • I have noticed that Bearer Management isn't included in Qt Mobility since Qt 4.7. I have tested the bearer example in a 6710 Navigator with Qt 4.7.1 installed (without Qt Moblity), and works as expected.

    So, seems to be a issue of Qt 4.7.1.

    Anyone knows something about it? Please, I'm stuck with this issue.



  • I'm currently facing the same problem of no configurations returned. I figured out, that the QtNetwork module moved from QtMobility to Qt in 4.7. Yet in Qt 4.7.1 there is still no Symbian support for bearer management and QtMobility still ships with the old bearer management code. So there are two QNetworkConfigurationManager classes and you probably have to figure out how to force the one of QtMobility.



  • I tried to compile the code with reference to mobility bearer in .pro file, also I tried without it, and the result has been the same that I explained in my firsts posts.

    Note that in 6710 Navigator I haven't installed Qt Moblity in device, and it works as expected.



  • Yes, you are right, it is just not working, found the S60 bearer code in Qt 4.7.1 shipped with the 1.1SDK...



  • Thanks unclewerner.

    I have opened a Qt bug ticket. I hope it fixed soon.



  • In case someone else cares about it: http://bugreports.qt.nokia.com/browse/QTBUG-17735 .



  • Yes, this is the bug ticket that I have opened minutes ago :)



  • Just add
    @symbian:TARGET.CAPABILITY = NetworkServices ReadUserData@

    In your .pro file.



  • I already have these capabilities in my .pro file



  • Did you run qmake after that? Do you have them in mmp file?
    I'm getting a list of 11 configurations from allConfigurations(); in my app. (N8, Qt4.7.2, Mobility 1.1.1)



  • Yes. I'm using Carbide, and qmake runs automatically after .pro was modified.

    Where I can download Qt 4.7.2 SIS file for Symbian^3 devices?

    If it works for you with 4.7.2... Could be a problem with 4.7.1 version only.



  • Well, its not hosted anyware yet. So you need to download and unpack whole Qt SDK 1.1 Beta to get it.



  • I already have installed Nokia Qt SDK 1.1 Technology Preview, but there is only SIS files for Qt 4.7.1.

    Now, I will download Qt SDK 1.1 to find Qt 4.7.2 SIS file.

    Thanks truf.



  • I just tested with Qt 4.7.2 in C7-00 and N8, and all works as expected.

    So, seems to be a bug only in 4.7.1 version.

    Thanks again truf.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.