[SOLVED]Build Qt for Tizen on Ubuntu 13.10: Stuck on Devices combo box not displaying "tizen (default for Tizen Device)



  • I am able to compile and install QT for Tizen on Ubuntu 13.10 but am stuck at the configuration stage:

    Configure Qt Creator

    Have completed Tizen configuration
    Cannot complete Tizen emulator-related configuration
    because
    “tizen (default for Tizen Device) "
    does not appear as a device option

    I have the emulator running prior to launch of QtCreator.

    I have also tried with a Tizen Phone plugged in

    Thank you for assistance,

    Clara McKenzie



  • Should also mention I can access both the emulator and the device from the TIzen IDE



  • Try to run sdb command(it is similar to android's adb and installed with Tizen SDK and Qt Creator uses it for device discovery):

    $ sdb devices

    I know that there were issues with sdb and libudev see:
    https://bugs.tizen.org/jira/browse/TIVI-2186
    and
    https://developer.tizen.org/forums/native-application-development/fyi-tizen-sdk-2.2.1-nov-9-2013-sdb-startup-problem-libudev



  • Thanks for your help :

    Here's the devices
    $ sdb devices
    List of devices attached
    emulator-26100 device small
    4df13b46255d6f00 device device-1

    I've gotten a bit further in debugging:
    This line is failing for me:
    cd /home/cmckenzie/dev/src/tizenbuildtools/qtcreator/plugins/tizen
    ==> build_and_deploy_tizen_plugin.sh: 65: build_and_deploy_tizen_plugin.sh: Bad substitution
    line 65 is
    "QTCREATOR_TIZEN_PLUGIN_BRANCH=${QT_CREATOR_VERSION:0:-2}"

    I'm also wondering if this is a problem that that QT Creator is 5.2.1 and QMAKE is the tizenbuildtools qmake in the Path is 5.2.2:

    • QT_CREATOR_QT_VERSION=5.2.1
    • echo 5.2.1
    • cut -d . -f1
    • QT_CREATOR_QT_MAJOR_VERSION=5
    • qmake -version
      • grepgrep -o Using Qt version [0-9.]* -o
        [0-9.]*
    • QMAKE_QT_PATH_VERSION=5.2.2

    <log too log>
    From http://git.gitorious.org/qt-creator/qt-creator
    d59f5c1..a6f12b3 3.1 -> origin/3.1

    • git checkout v3.0.1
      HEAD is now at 51af63b... Version bump
    • QTC_SOURCE=/home/cmckenzie/dev/src/tizenbuildtools/qtcreator/qt-creator-sources
    • echo Qt Creator source set to /home/cmckenzie/dev/src/tizenbuildtools/qtcreator/qt-creator-sources
      Qt Creator source set to /home/cmckenzie/dev/src/tizenbuildtools/qtcreator/qt-creator-sources
    • export QTC_BUILD
    • export QTC_SOURCE
    • cd /home/cmckenzie/dev/src/tizenbuildtools/qtcreator/plugins/tizen
      build_and_deploy_tizen_plugin.sh: 65: build_and_deploy_tizen_plugin.sh: Bad substitution


  • I don't think it is problem with Qt version. You can try with 5.2.1 - doesn't matter.

    When invoking:
    @
    export PATH=/home/tolszak/Qt/5.2.1/gcc_64/bin:$PATH

    QTC_BUILD=/home/user/Qt/Tools/QtCreator ./build_and_deploy_tizen_plugin.sh
    @
    I got following output:
    @
    found Qt Creator - version 3.0.1 build with Qt 5.2.1 in /home/tolszak/Qt/Tools/QtCreator
    HEAD is now at 51af63b... Version bump
    Qt Creator source set to /home/tolszak/workspace/tizenbuildtools/qtcreator/qt-creator-sources
    HEAD is now at 039d87c tizen plugin adaptation for QtCreator 3.0
    @
    And then output from make.

    I would like to mention that QtCreator 3.0.* are supported currently by alpha6.

    Also I will be on IRC (http://webchat.freenode.net/ channel #qt-tizen) in 20 minutes for about 4 hours so fill free to poke me, I can help with finding out what's wrong.



  • For Qt-Creator plugin build, my problem was the shell. Ubunti 13.10 lined /bin/bash to /bin/dash.

    To fix this:
    sudo dpkg-reconfigure dash

    For the device connection,my problem turned out to be the phone version. I needed to upgrade to 2.2.1:
    https://wiki.tizen.org/wiki/Flash_Tizen_2.2_Image_to_Reference_Device

    Thanks Tomasz for sorting both issues out


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.