[BUG POSTED] Qt 5.2.0/Qt 5.2.1: infinite recursion in androiddeployqt



  • I am using Qt5.2.0 under linux.
    I have successfully built an apk previously by compiling under qtcreator and then running:

    ../../android/Qt5.2.0/5.2.0/android_armv7/bin/androiddeployqt --verbose --input android-libdLarn.so-deployment-settings.json --ant ~/android/apache-ant-1.9.3/bin/ant --output android-build

    I recently updated my source code adding two new files. After updating my .pro file and rebuilding in qtcreator, I now get the following failure from androiddeployqt:

    • ...
    • Stripping libraries to minimize size.
    • Copying Android sources from project.
    • -- Skipping file /home/dlarn/dLarn/android/about.cpp. Same or newer file already in place.
    • -- Skipping file /home/dlarn/dLarn/android/about.h. Same or newer file already in place.
    • -- Skipping file /home/dlarn/dLarn/android/about.o. Same or newer file already in place.
    • -- Skipping file /home/dlarn/dLarn/android/android-build/about.cpp. Same or newer file already in place.
    • -- Skipping file /home/dlarn/dLarn/android/android-build/about.h. Same or newer file already in place.
    • -- Skipping file /home/dlarn/dLarn/android/android-build/about.o. Same or newer file already in place.
    • -- Skipping file /home/dlarn/dLarn/android/android-build/android-build/about.cpp. Same or newer file already in place.
    • -- Skipping file /home/dlarn/dLarn/android/android-build/android-build/about.h. Same or newer file already in place.
    • -- Skipping file /home/dlarn/dLarn/android/android-build/android-build/about.o. Same or newer file already in place.

    These error messages continue each time adding a new instance of android-build until it overflows the maximum path length and finally stops. (Note that it keeps checking the same files over and over again, each time with another android-build subdirectory added).

    Any ideas about what I've done to annoy androiddeployqt? (I've tried a complete rebuild of the project from scratch including having qtcreator rerun the .pro file -- no luck).

    Thanks.

    Chris

    P.S. I am able to build a linux version and windows version using the exact same code base. These run successfully. There are no build errors from qtcreator, qmake, make, or VSC++ for any of these builds.



  • I figured out what was going on. For more information, see:

    https://bugreports.qt-project.org/browse/QTBUG-37315

    Chris


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.