Important: Please read the Qt Code of Conduct -

Installation in Windows of Qt 5.2.1

  • I've tried to install Qt 5.2.1 but i didn't manage to do it.
    I've read lot of post and i think i've just added a lot of rabish to my environment.
    I set this local variables:
    ANDROID_NDK_HOST windows
    ANDROID_NDK_HOST android-9

    I add the path of Qt 5.2.1 bin directory to the global path environment variable.

    I have the annoing warning which sais:
    "qt version for architecture mips is missing"

    Is there some documentation about installing and test one of the examples in an android device?

    Thanks in advance for your help

  • I forgot telling that after doing that, i tried to build 'maroon' sample and i get this message:

    :-1: error: No rule to make target '................\adt-bundle-windows-x86-20131030\android-ndk-r9c\sources\cxx-stl\gnu-libstdc++\4.8\libs\armeabi-v7a\include\bits\c++config.h', needed by 'main.obj'. Stop.

  • Same problem here building a example project. It cant find the c++config.h
    I am gone try downgrading to a diffrent ndk just to so i can build a app

    C:\Code\android-ndk-r9d-windows-x86\sources\cxx-stl\gnu-libstdc++\4.8\include\utility:68: error: bits/c++config.h: No such file or directory
    #include <bits/c++config.h>

  • try this:
    Go to Project on the left side. Then select build from the kit you were using (from the top of the window), and take a look to "General" which are the first options.
    If you have checked Shadow build, uncheck it and try again. This worked for me.
    Now i have made so many changes, that i can't tell you why i have it working fine with that checked. Maybe if you try cheking it after first succes run it works. i don't know, but any way i think you would fix it.

  • Have you had any success with this problem?
    Any success getting a Qt app to run on Android at all?

    I am beginning to wonder if Qt on Android is even possible?

    I am having same issue on OSX, Ubuntu 14.0 32-bit and 64-bit.
    /Users/esutton/Qt5.3.1/5.3/android_armv7/bin/uic mainwindow.ui -o ui_mainwindow.h
    /Users/esutton/android/android-ndk-r10/toolchains/arm-linux-androideabi-4.8/prebuilt/darwin-x86/bin/arm-linux-androideabi-g++ -c -pipe -std=gnu++0x -g -g -gdwarf-2 -marm -O0 -fno-omit-frame-pointer -Wall -Wno-psabi -W -D_REENTRANT -fPIE -DQT_WIDGETS_LIB -DQT_GUI_LIB -DQT_CORE_LIB -I../../../Qt5.3.1/5.3/android_armv7/mkspecs/android-g++ -I. -I../../../Qt5.3.1/5.3/android_armv7/include -I../../../Qt5.3.1/5.3/android_armv7/include/QtWidgets -I../../../Qt5.3.1/5.3/android_armv7/include/QtGui -I../../../Qt5.3.1/5.3/android_armv7/include/QtCore -I. -I. -I../../../android/android-ndk-r10/sources/cxx-stl/gnu-libstdc++/4.8/include -I/Users/esutton/android/android-ndk-r10/sources/cxx-stl/gnu-libstdc++/4.8/libs/default/armeabi-v7a/include -I../../../android/android-ndk-r10/platforms/android-19/arch-arm/usr/include -o main.o main.cpp
    In file included from ../../../Qt5.3.1/5.3/android_armv7/include/QtCore/qcompilerdetection.h:845:0,
    from ../../../Qt5.3.1/5.3/android_armv7/include/QtCore/qglobal.h:74,
    from ../../../Qt5.3.1/5.3/android_armv7/include/QtGui/qwindowdefs.h:45,
    from ../../../Qt5.3.1/5.3/android_armv7/include/QtWidgets/qwidget.h:45,
    from ../../../Qt5.3.1/5.3/android_armv7/include/QtWidgets/qmainwindow.h:45,
    from ../../../Qt5.3.1/5.3/android_armv7/include/QtWidgets/QMainWindow:1,
    from mainwindow.h:4,
    from main.cpp:1:
    ../../../android/android-ndk-r10/sources/cxx-stl/gnu-libstdc++/4.8/include/utility:68:28: fatal error: bits/c++config.h: No such file or directory
    #include <bits/c++config.h>

Log in to reply