[Solved] < and > in comment body not shown



  • It's impossible to write in comment "lesser" and "more" math symbols (also used as brackets, and as HTML tags symbols).

    In title of topic I replaced this symbols to HTML ampersand_lt; and ampersand_gt;) but this way doesn't work in comment.



  • Hum. We shall fix. I passed that on to Marius to figure out how. ;)



  • [quote author="IrQX" date="1280367455"]It's impossible to write in comment "lesser" and "more" math symbols (also used as brackets, and as HTML tags symbols).[/quote]

    < and > straight from the keyboard, looks fine here.

    What browser and OS are you using, we can check if that is interfering with the comment box.



  • I used latest firefox under WinXP.



  • Now test again. It works only if there is space after "<" symbol.

    If I using < > symbols as tags (text between them) text doesn't shows.

    so, replacement _&_lt; and _&_gt; (without _) doesn't work in this case.



  • Thanks, we shall have a look!



  • We have made some changes, lets see if it helped :)

    <test>

    Normal HTML:

    <table border="1">
    <tr>
    <td>row 1, cell 1</td>
    <td>row 1, cell 2</td>
    </tr>
    <tr>
    <td>row 2, cell 1</td>
    <td>row 2, cell 2</td>
    </tr>
    </table>

    Now with entities instead:

    <table border="1">
    <tr>
    <td>row 1, cell 1</td>
    <td>row 1, cell 2</td>
    </tr>
    <tr>
    <td>row 2, cell 1</td>
    <td>row 2, cell 2</td>
    </tr>
    </table>

    </test>



  • Great success.

    This only works here on the "Beta Testing" forum for now btw, the other forums still has the old config.



  • Aha! Very nice. :)


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.