Deployment : libstdc++-6.dll - exception code 40000015



  • mingw.4.8
    Pulled all dll's out of mingw bin.

    Deployment :

    icudt51.dll
    icuin51.dll
    icuuc51.dll
    libgcc_s_dw2-1.dll
    libstdc++-6.dll
    libwinpthread-1.dll
    qt5core.dll
    qt5gui.dll
    qt5sql.dll
    qt5widgets.dll
    [platforms]->qwindows.dll
    [plugins]->qsqlmysql (with or without doe not matter much.)
    @
    Naam van foutmodule: libstdc++-6.dll
    Versie van foutmodule: 0.0.0.0
    Tijdstempel van foutmodule: 516ee7b6
    Uitzonderingscode: 40000015
    Uitzonderingsmarge: 00019d8d
    Versie van besturingssysteem: 6.1.7601.2.1.0.256.1
    Landinstelling-id: 2067
    Aanvullende informatie 1: e184
    Aanvullende informatie 2: e1843d81a9249701be5eb48a5a961d3b
    Aanvullende informatie 3: 840b
    Aanvullende informatie 4: 840bb4a6f17255fc33d46aeb7089f9d8@

    I have tried 5.2.0, 5.2.1. On 2 computers
    Tried quite some things the past 6 hours.
    It only works on the qt box.

    Please help.



  • When you deploy to a computer without Qt, do you install your app into C:\Program Files (x86)? If so, try somewhere else, like C:\Temp

    BTW, are all computers Win7 SP1?



  • The app is installed on data partitions.

    All 3(working source + 2 non working target pc's) are windows7 sp1 x64 .
    On one of the target pc's I even installed qt. (It's insane but what can i do?)


  • Moderators

    Hi,

    How many versions of MinGW do you have in your Qt box?



  • Hi, there is one in 5.2.0 and since last night also one in 5.2.1. (added 5.2.1)

    I've been able to do further testing.
    The same deployment that caused the

    @libstdc++-6.dll
    exception code : 40000015@

    On 1 pc is starting the ui on another computer. No functions work however.
    On exit I do get :
    @StackHash_2264
    exception code : c0000005@

    Same deployment, 2 different computers, different error.

    It does get weird now, perhaps a little prologue.
    Yesturday I tested the Original build (5.2.0) and got similar problems.
    I have installed qt5.2.1on this destination computer.
    When I came home I added 5.2.1 to the programming pc.
    I rebuilded it with both 5.2.0 and 5.2.1 (it should make no difference i think.)
    I then just added some "db.isOpen()" checks to functions at certain buttons that qo query's. And rebuilded 5.2.1 only.
    This works well on the source pc but cases the problems described above.

    I'm not at the remote destination pc. I have also added the 5.2.0 build on the memory stick. Being the single app.exe without any dll's in a folder it just works!

    So the Original 5.2.0 build used yesturday does not work.
    The same code rebuilded 5.2.0(not sure debug or release) after adding 5.2.1 to the source(without the "db.isopen()check" works as single .exe without any dll! (qt & mingw paths are in the path enviroment tho on this pc. I did not test this build on the other pc, I just included the single exe as a desperate last resort.)

    For now I have moved the working version to the hard drive (without dll's, I asume it works solely on the path enviroment included sources) so we can start processing data into the database.

    This however does not solve the rest of the problems tho.
    Tonight I will make some builds to see exactly wich one is working where and how. It all seems pretty arbitrary to me, even tho i'm sure it isn't.



  • Update :

    I do have an extra mingw in tools.
    This is the one used :
    F:\QT\Tools\mingw48_32\bin\mingw32-make.exe
    The other mingw's (in 5.2.0 & 5.2.1) are also 4.8.

    The one working build is a release build.

    I builded both 5.2 and 5.2.1 release.
    On the first non qt pc i still get the :
    @ Naam van foutmodule: libstdc++-6.dll
    Versie van foutmodule: 0.0.0.0
    Tijdstempel van foutmodule: 516ee7b6
    Uitzonderingscode: 40000015@
    Will see tomorrow wich one works on the other computer, if any.

    What could be wrong what can I do to correct it?

    1. What mingw must I use? The one in the qt 5.x versions, the one in tools or another? In path enviroment?
    2. Is it ok to have more qt's next to eachother (Just installed to see)
    3. I still need a qt path in envirment vars?
    4. Install reinstall everything (I kinda tried that by adding 5.2.1)?

    Also missing dll's :
    @API-MS-WIN-APPMODEL-RUNTIME-L1-1-0.DLL
    API-MS-WIN-CORE-WINRT-ERROR-L1-1-0.DLL
    API-MS-WIN-CORE-WINRT-L1-1-0.DLL
    API-MS-WIN-CORE-WINRT-ROBUFFER-L1-1-0.DLL
    API-MS-WIN-CORE-WINRT-STRING-L1-1-0.DLL
    API-MS-WIN-SHCORE-SCALING-L1-1-1.DLL
    DCOMP.DLL
    GPSVC.DLL
    IESHIMS.DLL@

    Will check these out later. Got to fix my bed :(

    It's just that I'm totaly clueless on this.



  • I think to keep you from going insane (i.e. get more clues), you need to see what DLLs from what directories are actually working with your app, and which are not.

    You can use "Sysinternals ListDLLs":http://technet.microsoft.com/en-us/sysinternals/bb896656.aspx . Just type Listdlls appname. You'll get a list of all the DLLs loaded for your app. Sort them and then time to start comparing!



  • Thx, i'll do this tomorrow evening!

    I've been to work now to get parts to fix my bed and used the opportunity to test the latest builds there too.

    I have installed qt5.2.1 at work. added to path. Both builds work there without dlls. Just the app.exe on desktop and done.

    Time to test my bed, been hell of a weekend and still need to catch up some sleep.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.