Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Qt creator: c++11 compilieren funktioniert nur bedingt Debian GNU/Linux



  • Hallo zusammen,

    letzens habe ich Qt creator in debian wheezy installiert. In den Repositorys von Debian befand sich soweit ich weiß die Version qtcreator (2.5.0-2) . Wenn ich einen Code habe der ohne c++11 nicht funktioniert möchte qtcreator diesen Code nicht compilieren obwohl ich @LIBS+=-lncurses CONFIG+=c++11@
    zu den Erstellungsschritten für qmake, in qtcreator , hinzufüge. Ich habe daraufhin qtcreator gelöscht und mir mal den Quellcode der aktuellen Version heruntergeladen. Dort habe ich exakt das gleiche Problem :(
    Ich sollte dazu sagen das mein Compiler g++-4.7 , c++11 ausreichend für meine Projekte unterstützt. Darum kann ich auch mein komplettes Programm, das ja c++11 braucht, problemlos mit einer Makefile compilieren.
    Wenn ich @QMAKE_CXXFLAGS += -std=c++11@
    zu meiner .pro Datei hinzufüge, dann kann ich auch von Qt creator erfolgreich compilieren.
    Meine Frage: Wie kann ich c++11 im qtcreator aktivieren? Auf meinem Notebook, auf dem momentan Ubuntu und qtcreator läuft habe ich damit keine Probleme.

    Gruß


Log in to reply