[SOLVED] How to create symlink for libs? Debian Wheezy.



  • I installed Qt 5.2 on Debian Wheezy with the Online Installer and I open the Qt Creator, then I created a new project and I build, but he returns this error:
    @:-1: error: cannot find -lGL
    :-1: error: collect2: error: ld returned 1 exit status@
    @16:52:53: Running steps for project SeriesGuidePC...
    16:52:53: Configuration unchanged, skipping qmake step.
    16:52:53: Starting: "/usr/bin/make"
    g++ -Wl,-O1 -Wl,-rpath,/home/tux/Qt/5.2.1/gcc -Wl,-rpath,/home/tux/Qt/5.2.1/gcc/lib -o SeriesGuidePC main.o seriesguidepc.o moc_seriesguidepc.o -L/home/tux/Qt/5.2.1/gcc/lib -lQt5Widgets -lQt5Gui -lQt5Core -lGL -lpthread
    /usr/bin/ld: cannot find -lGL
    collect2: error: ld returned 1 exit status
    make: *** [SeriesGuidePC] Error 1
    16:52:54: The process "/usr/bin/make" exited with code 2.
    Error while building/deploying project SeriesGuidePC (kit: Desktop Qt 5.2.1 GCC 32bit)
    When executing step 'Make'
    16:52:54: Elapsed time: 00:00.@

    Must be why the libs are not linked correctly in the system, because when I install Qt 4.8 using apt-get it usually works.


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    You are just missing the OpenGL development libraries

    Just call
    @sudo apt-get install mesa-common-dev@

    and you should be good to go

    Happy Coding !



  • Hi, I installed the mesa-common-dev and still returning the same error. :(


  • Lifetime Qt Champion

    Then also install

    @sudo apt-get install libgl1-mesa-dev@



  • It worked! Thank you! :D


  • Lifetime Qt Champion

    You're welcome !

    Since you are all setup now, please update the thread title prepending [solved] so other forum users may know a solution has been found :)


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.