Qt World Summit: Submit your Presentation

"Needs a compiler set up to build" type issue

  • I got a brand new w8 (I know I know, but unavoidable) laptop and I have tried installing many different flavors of Qt but for all of them, when I try to run a project I get the "Qt Creator needs a compiler set up to build" error. I have Visual Studio 2013 installed and I go through the hoops to manually select a compiler and whats even more baffling:


    Anybody have any thoughts? Thanks!

  • Okay looking at my own error, I hadn't noticed the '13 / '12 mismatch. I suppose there's no way (short of compiling qt myself) to get things working without installing the whole of visual studio 2012?

  • Perhaps install Qt for the free MinGW compiler as a workaround.

  • I sucked it up and just installed vs2012, alas. Thanks or the suggestion though!

  • Good. (MinGW works fine but for example, the QtCreator you install are built with VS2010, so if you want to make a plugin for it using MinGW, you'll first have to rebuild and change to a MinGW-flavored build of QtCreator.)

    BTW if you're going to deploy Qt apps for Windows XP or Windows 2003 server, you need to update your VS2012 installation. Update 4 (the latest and the greatest) works fine.

  • ^

    this guy , he's right , I had the same problem when I installed qt " i'm new " I solved it by installing VS2010.

Log in to reply