Strange build behaviour in Qt 5.2.1 for Windows 32-bit (MinGW 4.8, OpenGL, 634 MB)



  • I recently installed Qt 5.2.1 for Windows 32-bit (MinGW 4.8, OpenGL, 634 MB) in a new Windows 7 Machine (VritualBox). But when I try to "Build All" one application I get a recurring call to qmake:

    @09:23:00: Running steps for project odkviewer...
    09:23:00: Configuration unchanged, skipping qmake step.
    09:23:01: Starting: "C:\Qt\Qt5.2.1\Tools\mingw48_32\bin\mingw32-make.exe"
    C:\Qt\Qt5.2.1\5.2.1\mingw48_32\bin\qmake.exe -spec win32-g++ -o Makefile ..\odkviewer\odkviewer.pro
    C:\Qt\Qt5.2.1\5.2.1\mingw48_32\bin\qmake.exe -spec win32-g++ -o Makefile ..\odkviewer\odkviewer.pro
    C:\Qt\Qt5.2.1\5.2.1\mingw48_32\bin\qmake.exe -spec win32-g++ -o Makefile ..\odkviewer\odkviewer.pro
    ....
    @

    And nothing happens... Its been three hours since I clicked "Build All"

    Any idea what is wrong?



  • Hi, I've seen this problem discussed before, e.g.

    "Endless loop of qmake.exe":http://qt-project.org/forums/viewthread/30654

    Maybe a solution for you exists in that thread...



  • Hi,

    This happened when I moved my whole project from QT Android Linux 32 bits to QT Windows MinGW 4.8 and tried to build it. I don't know what causes the problem but if I create a new project and add the files manually the build work fine.

    Carlos.



  • Hi qlands,
    I have same problem and tried to do as you said but didn't find anywhere to import files in a new project. Could you tell exactly how it can be done?
    Is it possible that I missed the ".config" file for Win OS?
    Klara


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.