[SOLVED] iOS Deployment Problem

  • Made my first iOS application, then spent most of yesterday going through the ritual of provisioning profiles, certificates etc. on Apple developer website. I now have the app verified and have built an ipa and plist.

    I would like a few people to beta test it, so I have added their Device ID's into Apple Developer console.

    When trying to install via iTunes, on my iPad it just sits saying "Installing". On an iPod Touch it fails to install near the end.

    Is this more something that should be pointed on an Apple forum? Or am I missing some vital Qt files?


  • Hi, if your iPad loops on "installing", perhaps it is some problem with the Device ID's (it happens to me sometimes, even though I've added them on Apple's web page). Here's what you can do to check it:

    Rename your .IPA file to .ZIP and unpack it. Inside you'll find a single folder called Payload. Inside that you'll find your app. Open it the usual way "Show Package Contents". Inside that folder locate the file embedded.mobileprovision. Open the file with a texteditor like TextEdit. Locate the key "ProvisionedDevices" and make sure your iPad's UDID/DeviceID is present in the array list. If it's not you'll need to refresh your certificate on your Mac.

    Another thing that might go wrong, check your IOS apps' DLL dependencies, by running otool -L on it. (The app executable is in the same folder as that file embedded.mobileprovision.) Perhaps the Qt DLLs are not correctly referenced or something like that...

  • Thanks, you are right and I have just managed to sort it. I had attached no Device ID's to the provisioning profile.

    I figured it out when I tried to upload the the ipa to testflight. It gave me more info than anything else.

    Qt DLLS were fine.

    Thanks again, Carl

  • Aha, good. I've read about testflight but haven't checked them out. Maybe I will, it's a good idea next time I run into this problem :-) /Rgrds Henry

Log in to reply