Important: Please read the Qt Code of Conduct -

[SOLVED] Qt5.2.1+EGLFS / WebKit2 running on i.MX6q ?

  • Hi,

    I've build Qt5.2.1+EGLFS for imx6qsabresd board, based on a yocto sysroot (master branch). I'm able to run most Qt examples, including the Qt5_cinematic_experience.

    Now, my focus is on WebKit:

    • examples (fancybrowser, QtTestBrowser) based on WebKit1 are OK = web content is displayed correctly
    • examples based on WebKit2 are not OK = web content is not displayed, even if the 2 processes (UI and
      QtWebProcess are running).
    • flickrview
      only the thumbnails are shown and the content (where the selected image is supposed to be) stays empty
    • MiniBrowser (WebView qml element)
      only the browser ui (reload button, back button, url bar, etc) is shown while the loaded page is not

    I'd like to know if some you are experiencing the same kind of issues and/or have managed to make WebKit2 working on the same platform?

    Any advise to investigate the problem is more than welcomed !

  • Hi,
    I am experiencing the same with you. I have also tried qt 5.3.0 alpha and i got the same result. I haven't figured out yet what's wrong. As i see it the handling of the rendering surface is almost the same as on qt 5.2.0 .
    Maybe i am missing something.

  • Hi,

    For those who are not following the meta-freescale mailing-list: the issue is fixed thanks to the patch provided by Prabhu Sundararaj ( )

    With this patch, web content is displayed correctly on the i.MX6 platform when WebKit2 is used and you can enjoy the benefit of some accelerated functions.

  • Hi,
    Can you please check the link above. Seems to be corrupted or something.

  • Oops! I've added a space before the 2 parenthesis to fix it.
    Should be OK now.

  • Thanks. I shall update my sources.


Log in to reply