[Solved after Days of Trouble] Self Compiled Qt + Creator: Creator looks for Standard Librarys in Different Folders



  • Evening.

    I have compiled Qt 5.2.1 and Qt Creator 3.0.1 with MingW32 Version 4.8.2 Revision 3. I have not changed any Version of Python, ICU, OpenSSL or something else. The Problem never occured with Qt 5.2.0 and Qt Creator 3.0.0.

    Qt is installed with the prefix Option during compiling and after that with "mingw32-make install" in D:\Qt-Build.
    Qt-Creator is installed with D:\Qt-Creator\ with the same Operations.

    The SourceCode is in C:\qt-everywhere-opensource-src-5.2.1

    When i open Creator, it does NOT Found:

    • QMainWindow
    • QObject
    • Webkitwidgets
    • QMenue

    and some other Stuff. What irritates me: After around 20 Minutes, it found some of the Files in the SourceCode Folders. And some of them in D:\Qt-Build. "windows.h" is used from the MingW Folder.

    Even the Documentation cant be found.

    I have no Idea what else i can do. I have already copied the Files from D:\Qt-Build\Include and D:\QT-Buld\Lib to D:\Qt-Build\qtbase\include and D:\Qt-Build\qtbase\lib. Nothing works.

    All Paths are the same as for Version 5.2.0

    The only thing i have changed is the MingW Compiler. I switched from 4.8.1 Revision 5 to 4.8.2 Revision 3. Both Versions are Posix-Dwarf. Could that be the Problem?

    I have recompiled Qt + Creator 4 Times already. It always took 15 Hours on my Phenom 2 X4 965 BE 3.6 GHz, 16GB Ram, Windows 7 x64 Machine. With SourceCode on HDD 1 and the Install Folder on HDD 2. Any Tips? Should I File a Bug Report? Man Qt is getting worse / makes more Compiler Problems with every new Version -.-

    Thanks
    Oliver



  • Hmm i still cant compile anything and Creator still says

    Fehler: Unknown module(s) in QT: webkitwidgets

    I have NOT changed anything in the SourceCode or the .pro File. In the self compiled Version of Qt 5.2.0 everything was fine.

    Why does Creator look in the SourceCode Folder? The Header Files there are not meant and does not work for compiling Stuff. This totally nonsense.

    The Qt Path if also Set. I am out of Ideas. I hate Qt more and more every Day -.-



  • Has no one a Idea what the Problem could be?


  • Moderators

    Hi,

    Can you check if the WebKit modules were successfully compiled?



  • [quote author="JKSH" date="1392866560"]Hi,

    Can you check if the WebKit modules were successfully compiled?[/quote]

    Yes the Folders for Webkit and Webkit-Examples are in Place.
    And QWebView is shown in the Designer Part of Qt Creator.

    But "QT += core gui webkitwidgets" in the .PRO File still give an Error.

    That is why i find it so strange.

    The Problem is: Some Headers are read from the SourceCode Folder on Drive C: (the Files i used to compile Qt) and other Header Files are read from the correct D:\Qt-Build Folder. But i dont have changed any Path Settings.

    I just deleted the old Subdirectories of Version 5.2.0 in D:\Qt-Build and re-compiled Qt 5.2.1 in this Folder. After the compiling, i ran "mingw32-make install" like with Version 5.2.0



  • Oh wow Forum works again. Anyway: I have updated Git to 1.9.0 Experiental and Sqlite to 3.8.3.1 and have recompiled Qt 5.2.1

    Right now i am compiling Qt Creator 3.0.1
    Will check again when compiling of Creator is done.

    BTW / OffTopic: The Bug with "Help.json" and "Error 2" still exist: I need to copy the File "Help.json" from the Target Install Folder D:\Qt-Creator\src\plugins\help to the SourceCode Folder and restart Mingw32-make.

    Why is such a simple thing still not fixed? Aside with the QBS Problem? A Bug Fix Release should Fix Bugs or am i wrong?? /OTEnd



  • Next Bug: Need to copy the File Qmldesigner.json too. File does not exist within the SourceCode Package -.-

    Why come every new Version with a new Bug? Does the Packages not get checked enough during Beta?



  • New Problem: Creator is compiled. But when i start Creator, it crashes with a Error Message:

    "Terminate called after throwing an instance of std::bad_alloc
    what<>: std::bad_alloc"

    What does this mean? Never had this Error before.



  • Recompiling Creator the 7th Time now -.-


  • Moderators

    Hi,

    If it didn't work 6 times, I doubt it will work the 7th time. Let's try to find the root of the problem.

    What happens if you switch back to your previous compiler?

    What happens if you try to compile Qt 5.2.0 + Qt Creator, using your current compiler?



  • Morning.

    The out come is as follows:

    1.) It still dont work
    2.) Compiling Qt 5.2.0 and Creator 3.0.0 works fine. And no Problem within Creator

    Making a last run now. If that dont work, i am forced to completely switch back to 5.2.0 and Creator 3.0.0

    But thanks :)


  • Moderators

    If you don't need a bugfix from Qt 5.2.1, then 5.2.0 should still be a good choice.

    An alternative is to use a pre-built package: http://sourceforge.net/projects/mingwbuilds/files/external-binary-packages/Qt-Builds/

    Good luck!



  • Sigh 7th Creator Compiler run is done. No more complaining about missing Headers or the "missing but still existing" webkitmodule

    Now i have to check why he still reads all the Files from the SourceCode Directory. Will play around with qt.conf



  • Finally: I ran manually "mingw32-make install" -> now no Startup Error Messages any more. But i still need to check some Projects and the OpenSSL Configuration Depencies.

    With Qt 5.2.0, this Extra Step was never necessary, if I used --PREFIX with qmake.

    I keep this Topic open til i have done a deep check. This will take some time.

    Have a great weekend everyone! :)
    Oliver


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.