Building Qt5 on x86_64 Debian Jessie with gles2



  • Hello,

    I want to try QtWayland and QtCompositor, so I have to build Qt from source.

    I pulled the latest stable (I guess 5.2.1) from the repos.

    I run :
    @./configure -developer-build -opensource -nomake examples -nomake tests -confirm-license -no-gtkstyle -egl -opengl es2@

    However I get :
    @Running configuration tests...
    The OpenGL ES 2.0 functionality test failed!
    You might need to modify the include and library search paths by editing
    QMAKE_INCDIR_OPENGL_ES2, QMAKE_LIBDIR_OPENGL_ES2 and QMAKE_LIBS_OPENGL_ES2 in
    /home/doom/git/qt5/qtbase/mkspecs/linux-g++.
    @

    Even if I have the following packages installed :
    @libglapi-mesa-dbg
    libgles1-mesa
    libgles1-mesa-dbg
    libgles1-mesa-dev
    libgles2-mesa
    libgles2-mesa-dbg
    libgles2-mesa-dev
    libglapi-mesa
    @
    And gl2.h in /usr/include/GLES2

    I added the following lines to the mkspec :
    @QMAKE_INCDIR_OPENGL_ES2 = /usr/include/GLES2
    QMAKE_LIBDIR_OPENGL_ES2 = /usr/lib/x86_64-linux-gnu @

    (Location was checked with locate)
    But it doesn't work.
    Help please !


  • Lifetime Qt Champion

    Hi,

    I can't answer this one directly but try running configure with the -v option, it should give you more information about the failure that might give you more clues about what you need to install.

    Hope it helps



  • configure -v -d -d -d -d
    ;)


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.