QQuickPaintedItem with width or height bigger than 2048 doesn't show on Arm Linux



  • It took me a while to figure out why my QQuickPaintedItem isn't shown on Arm Linux while it IS shown on Windows - eventually after tinkering with many properties I came to the conclusion that if it's width (or height) are wider than 2048 - it won't be shown.

    This is a change that came with Qt 5 QtQuick 2, in Qt 4.8 QtQuick 1 I used a DeclarativeItem for the same painted width and it worked just fine.

    Does anyone have a clue how to begin to solve this?

    Thanks!



  • Sounds like a limitation of your openGL stack on your arm system. No clue how to get around that, I don't know enough about openGl to be of assistance with that.



  • Have you tried it with a smaller image, so we can narrow the possible faults.



  • Andre - will look into this, thank you

    one - yes, I have been tinkering with the sizes, the item vanishes and leaves a black backdrop when the width or height fo over 2k - 2048



  • Alright, could you please create a Image with its width or height over 2k and scale it down to about 0.5 or 50% of its normal Size. Is it still black or does it display the Image?



  • Thanks - scaled down it still isn't displayed and shows black



  • Okay, it doesn't seems like the Problem is the opengl stack. Since i remember your imageprovider would provide a new image in the scaled size, so the image would be smaller than 2k and the opengl stack could show it. The problem should be your imageprovider. It seems like he cant properly load images bigger than 20002000 or 4 Megapixels. I haven't worked with QQuickPaintedItem yet so i probably can't help you, but i will try to.
    Oh and another thing, could you please load a Image smaller than 2k
    2k, for example 10241024 and scale it up to about 20482048 or more and post what happened.



  • Did it just now, 1024 scaled 3 - it shows



  • Alright then it is not your opengl-stack. I'm not sure about the problem but it probably is some bug or some arm-unsupported stuff in your imageprovider. Please feel free to post your issue here: "Bugreports":https://bugreports.qt-project.org/issues/?jql=


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.