Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

[SOLVED] Qt Android on Mac OSX Maverick - ant path problem!



  • Hello,
    I have configured all necessary things on mac to build android Qt app, but I am having problem with ant path that is sticking deploy on android.

    I know on Mac ant is well supported (present in /usr/bin/ant), but in Android options, it is asking for location that is not /usr/bin.
    Moreover if I get ant from apache site, again I set that directory as ant location, but deploy process tells me that location is a directory!

    So what do I have to do to get rid of this problem?!?

    Thanks to all
    Gianni



  • Hi Gianni,

    I think you should put the FULL path to the executable, instead of the path to the directory the executable is contained in. For instance, in Windows I put

    @<PATH>\Ant\bin\ant.bat@

    and the deployment started to work correctly.

    Bests,
    F.



  • I know that, I'am deploying to android also using windows, but if I put full path it always tells me that is wrong.
    It seems Qt form options doesn't permit to put the exe file





  • [double post]



  • Yes I did,
    I am using Mavericks and whereis doesn't exist!
    anyway, I found where ant is: /usr/bin/ant but again it doesn't matter because Qt rejects it.
    So what I can try is this:
    @
    $ant -diagnostics


    ANT PROPERTIES

    ant.version: Apache Ant(TM) version 1.9.2 compiled on July 8 2013
    ant.java.version: 1.6
    ant.core.lib: /opt/local/share/java/apache-ant/lib/ant.jar
    ant.home: /opt/local/share/java/apache-ant
    @

    And use the last diagnostic voice.


  • Lifetime Qt Champion

    Hi,

    Do you have ant installed through macports ? If so it might be this one that you should try use

    You can check the path of a command using "which"

    Hope it helps



  • I think ant was already installed on Mac OS. I don't know if "which" exist, anyway I'll give it a try.



  • Ahhh mac OSX is a very sh**t

    Finally, I put this and it is working:
    /usr/local/ant/bin/ant

    latter ant is executable.


Log in to reply