Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Issue while installing QT 5.2.0 in utuntu



  • HI,
    I downloaded
    qt-everywhere-opensource-src-5.2.0.tar.gz
    and followed steps to install following website.
    https://qt-project.org/doc/qt-4.8/qt-embedded-install.html

    The issue i am facing is :

    Project ERROR: Unknown module(s) in QT: quick
    make[3]: *** [sub-scanner-install_subtargets] Error 3
    make[3]: Leaving directory /root/qt-everywhere-opensource-src-5.2.0/qtconnectivity/examples/bluetooth' make[2]: *** [sub-bluetooth-install_subtargets] Error 2 make[2]: Leaving directory/root/qt-everywhere-opensource-src-5.2.0/qtconnectivity/examples'
    make[1]: *** [sub-examples-install_subtargets] Error 2
    make[1]: Leaving directory `/root/qt-everywhere-opensource-src-5.2.0/qtconnectivity'
    make: *** [module-qtconnectivity-install_subtargets] Error 2

    post make i am getting this error and make install also i am getting this error .
    Not able to proceed further .
    can any one help ASAP.
    Let me know if you require more information.

    Thanks


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    You are following a Qt 4 guide to build Qt 5, this one won't work. Qt Embedded is Qt 4 only, so the question is: do you need Qt Embedded in which case you should download the latest Qt 4 (or clone it)

    Or do you want to cross-compile Qt 5.

    On a side note, don't do it as root, the install step only might need root access.


Log in to reply