[blackberry] Debugging cascades app under QtCreator



  • Hello, forum!

    I've got an issue trying to debug my blackberry cascades app under QtCreator 3.0 (everything works fine with Momentics).
    Here's an issue: during debugging I am able to use breakpoints and step-by-step executing, but I can't see my local variables values.
    It seems like a python problem - I'm getting this message in the debugger's log:

    @>&"Traceback (most recent call last):\n"

    &" File "<string>", line 1, in <module>\n"
    &" File "/opt/qtcreator-3.0.0/share/qtcreator/debugger/gdbbridge.py", line 2, in <module>\n"
    &" import binascii\n"
    &"ImportError: No module named binascii\n"
    &"Error while executing Python code.\n"
    258^error,msg="Error while executing Python code."

    <...>

    &"Undefined command: "bb". Try "help".\n"
    263^error,msg="Undefined command: \"bb". Try "help"."
    dDUMPER FAILED: 263^error,data={msg="Undefined command: \"bb". Try "help"."}@

    Also I've checked python's version in the NDK - it's 2.7.2.
    As far as I understood QtCreator is trying to run some python script "qtcreator-3.0.0/share/qtcreator/debugger/gdbbridge.py" and can't do this using python from NDK, because there's no built-n module called "binascii".

    I've tried to run this script using my 'system' python (2.7.3) and it works fine - at least there're no problems with modules.

    Does anyone got any idea of solving this?

    P.S. I've tried to replace python in the NDK with my 'system' python, but got an error saying something about wrong ELF classes, so python wasn't able to event start...


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.