Newbie trying build Qt4 project with maia openSSL library



  • Hello,

    I have a software designed with Qt4 from an other developper and I am trying to build again. I passed some difficulties but now I cannot find solution for a new problem : I have some errors due to incomplete type around QSslConfiguration.

    In file *.pro I checked have QT += network
    I see in code of Qt there are some macro #ifndef QT_NO_OPENSSL disabling the code after (using Qt Creator IDE). Should I use an openssl option somewhere ?

    I am using Qt4.8.5 compiler but may be I should use an older one.

    Thank you for your attention.
    Vincent


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    If you have incomplete type error it generally means that you are missing an include.

    Hope it helps



  • Thank you SGaist.

    At the moment, I got around the problem using QT5 and folowing version of maia : https://github.com/wiedi/libmaia

    Regards


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.