Qt3D in Qt5



  • Hello, here:

    http://doc-snapshot.qt-project.org/qt3d-1.0/qt3d-building.html

    I read:

    bq. If you're looking for Qt 3D on Qt 5, please check for a recent Qt 5 release or source package, as Qt 3D is now a Qt 5 Essential and ships as part of Qt 5 and the Qt SDK

    I installed the SDK of 5.2.0 but I can't find any Qt3D reference. I checked I selected both QtEssential and QtAddOn modules.

    Mark


  • Moderators

    Hi,

    Qt 3D is still a work in progress, and has not been released yet. The sentence "Qt 3D is now a Qt 5 Essential and ships as part of Qt 5 and the Qt SDK" is wrong, unfortunately.

    Notice that your link has the word "snapshot" in it. Snapshots docs are unofficial and unreleased, so be wary when reading them. The latest official documentation is at http://qt-project.org/doc/qt-5/index.html



  • Thanks for the answer.

    This one is reliable?

    http://qt-project.org/wiki/Qt3D-Installation

    I'm trying to compile under Windows 7 (mingw) but I get the following errors:

    @mingw32-make[3]: Leaving directory 'c:/Development/Qt/qt3d/src/threed'
    mingw32-make[2]: Leaving directory 'c:/Development/Qt/qt3d/src/threed'
    cd quick3d/ && ( test -e Makefile || c:/Development/Qt/5.2.0/mingw48_32/bin/qmak
    e.exe C:/Development/Qt/qt3d/src/quick3d/quick3d.pro -o Makefile ) && c:/Develop
    ment/Qt/Tools/mingw48_32/bin/mingw32-make -f Makefile install
    /bin/sh: c:/Development/Qt/5.2.0/mingw48_32/bin/qmake.exe: Invalid argument
    Makefile:107: recipe for target 'sub-quick3d-install_subtargets-ordered' failed
    mingw32-make[1]: *** [sub-quick3d-install_subtargets-ordered] Error 126
    mingw32-make[1]: Leaving directory 'c:/Development/Qt/qt3d/src'
    makefile:55: recipe for target 'sub-src-install_subtargets' failed
    mingw32-make: *** [sub-src-install_subtargets] Error 2
    @

    I'm not a makefile expert and I don't understand what is the problem.

    I know Qt3D is still a work in progress but do you think is usable yet? The QGLWidget improvements will save a lot of work!


  • Moderators

    I haven't built Qt 3D myself for many months, so I don't know what the current state of the module is.

    I do know that lots of work is being done behind-the-scenes, and they are not available on git (see http://qt-project.org/forums/viewthread/30921 ). That means, if you write code that uses the current git version, it might be incompatible with the final released version because the API will probably change.

    Anyway, see http://qt-project.org/forums/viewthread/22858 for slightly different instructions.



  • I will try again but if I'm not wrong I've already tried to issue just "make" but nothing changes.

    How to know when it will be officially released?


  • Moderators

    [quote author="Mark" date="1390374411"]How to know when it will be officially released?[/quote]We'll have to wait for an announcement. It will come when it's ready.


  • Moderators

    The plan is to include it in Qt 5.3 or Qt 5.4. Sean and others are putting a lot of work into it, they want the thing to be really well polished before officially releasing.



  • I find these Qt3D delays frustrating too.
    Since almost one year I'm following any sign of life of it (ML, GIT, blogs, etc) and still, nothing at all.

    I've seen lot of people requesting it. Even a preview...a bit...anything really, but Digia/KDAB closed the doors instead of opening them (see Harmer's email saying they're working on a private GIT repo)
    Normally, if a company sees a feature is very requested, they put more resources to work on it. I guess this is not the case.

    I think this behaviour is blocking a lot of interesting projects. Mine too.
    I know everything could be done directly using OpenGL qtbase classes, but if someone is not a 3D developer, they can get lost in 5 minutes.

    In the meantime web based projects like three.js are flying very high and getting awesome results.

    I'm a Qt lover, so I think I have no choice other than waiting some more :(
    (just wanted to share my view on this)



  • Hi,

    I've got a similar problem: I was able to build Qt3d in QtCreator though I needed to relocate some paths according the header files.

    But when I try to make it, it says:
    make[2]: Nothing to be done for `install'

    Am I missing anything?


    OS: OS X 10.9.2
    Qt: 5.2.1

    Cheers



  • I have similar problem with QT3d building on windows.

    Link to my post http://qt-project.org/forums/viewthread/40138/



  • Any rumors on the release date for Qt3D? I am looking forward to it's official release!!!


  • Moderators

    Here are the notes from Qt Contributors Summit (last week). "Link":http://qt-project.org/groups/qt-contributors-summit-2014/wiki/Qt3D.

    Bottom line: it is still not ready.



  • Qt3D is now scheduled to make it into Qt 5.5.0.
    So we still have to wait about 6 months.

    I hope there will be a sort of tech preview right after 5.4.0 as I've heard rumours about.
    In the meantime it can be built from sources and it's already getting a good shape.
    Can't wait to code wonders with it ! :)


  • Lifetime Qt Champion

    Hi,

    Nothing stops you from trying the wip/newapi branch ;)



  • [quote author="SGaist" date="1413239182"]Hi,

    Nothing stops you from trying the wip/newapi branch ;)[/quote]

    Nothing DID stop me :)
    I'm following the progresses on that branch since months and when I can I give them a try (on Linux)


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.