Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Problem with qt 5.2 in linux



  • I downloaded Qt 5.2 installation from "here":http://qt-project.org/downloads and run it (ubuntu/debian 32 bit). All went good, qt got installed to /opt/qt5.2 directory and I tried to run qt creator, but all I got was this:
    Failed to load core: /opt/Qt5.2/Tools/QtCreator/lib/qtcreator/plugins/QtProject/libCore.so: Cannot load library /opt/Qt5.2/Tools/QtCreator/lib/qtcreator/plugins/QtProject/libCore.so: (/usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.15' not found (required by /opt/Qt5.2/Tools/QtCreator/lib/qtcreator/plugins/QtProject/../.././libQt5CLucene.so.5))
    So I've tried online installer but went same.
    sudo /sbin/ldconfig -v didn't change a thing, still same.
    It seems I have all dependencies as listed in "this page":http://qt-project.org/doc/qt-5.1/qtdoc/requirements-x11.html but its for 5.1 and I didn't find similar page for qt 5.2 so maybe I miss something.

    checked for glibcxx versions but its not there
    :~# strings /usr/lib/libstdc++.so.6 | grep GLIBCXX
    GLIBCXX_3.4
    GLIBCXX_3.4.1
    GLIBCXX_3.4.2
    GLIBCXX_3.4.3
    GLIBCXX_3.4.4
    GLIBCXX_3.4.5
    GLIBCXX_3.4.6
    GLIBCXX_3.4.7
    GLIBCXX_3.4.8
    GLIBCXX_3.4.9
    GLIBCXX_3.4.10
    GLIBCXX_3.4.11
    GLIBCXX_3.4.12
    GLIBCXX_3.4.13
    GLIBCXX_FORCE_NEW
    GLIBCXX_DEBUG_MESSAGE_LENGTH

    Any idea what can I do with it? I am using ubuntu 10.04. I tried to find GLIBCXX_3.4.15 but as I found it could mess up my system so that's not good solution.


  • Lifetime Qt Champion

    Hi,

    You will have to build Qt yourself.

    The dependencies between 5.1 and 5.2 didn't change so don't worry with that


Log in to reply