Creator 3 and Qt 5.0.2 [SOLVED]



  • Hi all. (My first post here.)

    Should i be able to use Cretator 3 with Qt 5.0.2?

    I am using Mint 16 - AMD64 and am having troulbe trying to find a combination that wil run the examples/tutorials without errors.

    The error I get now is:

    bq. :-1: error: Unknown module(s) in QT: quick qml

    Output of qtchooser -list-versions:

    bq. qt5-x86_64-linux-gnu
    qt5
    5
    default

    TIA


  • Moderators

    welcome to devnet

    yes (and no).

    In general you can use Qt creator with Qt lib version, but you have to distinguish what and where. Each version of Qt creator uses also Qt libs. For the pre-build Qt creator is shipped with a particular set of Qt libs. They are used to run Qt creator. You cannot exchange those (at least not in general). Qt creator is an IDE also based on Qt libs.

    The next step is that you are using Qt creator as an IDE to develop your own applications using any version of Qt libs. Those libs should be kept separate from the ones required for the IDE's operation. Especially when deploying an application you to choose the ones you used for building your application and not the set shipped with creator. This is typically confusing people.

    Previous Qt creator versions have been still shipped with Qt 4.8 for instance, but the Qt libs environment and source was already for Qt5.0. These version numbers make already obvious that deleting one set or the other is not really healthy.

    to make you life easier I would recommend to download the most recent combination from the "download page.":http://qt-project.org/downloads As it looks you are starting to use Qt and you are not really bound to any version.

    However, later on you can add new Qt lib versions (or older ones) in case you need. Also you might change creator version and keep older versions.



  • I would like to be able to use the Mint package tool if I can because in the past various Linux distros have run into problems when doing an upgrade with 'non-native' apps installed. Having said that when I install Creator with the package tool and click on 'examples' a small sort-of empty window appears in the upper left corner of the screen and the program shows three or four icons in the task bar and becomes so un-responsive that I have to go into the terminal and kill it with a -9 to get rid of it. I suppose that's probably a problem for Mint or Ubuntu or Debian, not Qt.

    So, getting back to the subject, there is no problem running different versions of Qt and different versions of Creater on the same machine?

    How do I keep the libs seperate? Mint just installs it's where it wants to and then seems un-aware of anything I install outside of the software manager; current Mint using 5.0.2.

    I have a feeling it's going to be a while before I get this all figured out.

    Thanks for the help.



  • I followed your advise and downloaded the 5.2 package and installed it into /usr/share/Qt5.2.0. Now when I try to run the 'Transistions' tutorial project I still get the "Project ERROR: Unknown module(s) in QT: quick qml" error.
    What needs to be done to get past this?
    Thanks
    (ps. for some reason the block quote didn't work here.)


  • Moderators

    You are using the examples and tutorials coming with the freshly installed version?

    Sorry, I am a windows guy. I have used Qt libs on Ubuntu linux before and I am restarting to use linux (embedded) for a project. Therefore, my knowledge is quite limited there.

    In general the examples and Qt libs shall cooperate well when used from the same version. Since you have installed a consistent SDK as from the top of the download page, it should work together.

    With Ubuntu I had faced version problems, because an older version was shipped in the repository. That is all I remember.

    You might to check in Qt creator the settings for kits, compilers and Qt versions. They should reflect what you expect. Furthermore, I fear I cannot help you.

    Good luck.



  • Thank you - yes I am, but I just realized Creator had defaulted to using the wrong kit. When I changed it to use the 5.2 kit things went better. Still, because I am also working through a slightly older tutorial from the website, I had to monkey around with the includes so it could find where QApplcation is now.

    I'll try and mark this solved.


  • Lifetime Qt Champion

    Hi,

    If you are having trouble with widgets related element your are just missing

    @QT += widgets@

    in your pro file


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.