Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Cc1plus.exe: out of memory allocating 149709 bytes



  • Hi,
    I am trying to run a little test program using the point cloud library: http://pointclouds.org/. I use the code from this page: http://pointclouds.org/documentation/tutorials/hull_2d.php.

    Interestingly everything works fine when I compile and run it in CodeBlocks with MinGW 32-bit and gcc version 4.7.2.

    But when compiling it in Qt Creator (Qt 5.1.0, MinGW 32-bit gcc 4.8), I receive following error:

    cc1plus.exe: out of memory allocating 149709 bytes

    I already did some research and tried following suggested configurations with no success:

    • QMAKE_CXXFLAGS += -O0

    • command line arguments for make: -Wl -large-address-aware

    Since everything works fine in CodeBlocks it must be Qt related. Do you have any idea how to solve this?



  • So, I tried to find out, wether the problem is really Qt related or gcc version related.
    I ran my code in CodeBlocks again but this time pointed the compiler to path\to\Qt\Qt5.1.0\Tools\mingw48_32.
    And now the same error occurs! So does this mean, it is only gcc version related?


Log in to reply