Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Can't install Qt 5.2.0 on Mavericks



  • As the title says, I can't install Qt on Mavericks.
    The setup first tells me that I need to have XCode Command Line Tools installed.
    If I continue the installation, it gives me an error about not being able to invoke otool.

    The problem is that I have the Command Line Tools installed.
    I tried to reinstall them but to no avail.

    Any guidance on this? I'm running OS X 10.9.1 and I've tried the online and offline installers.
    Thanks in advance.


  • Qt Champions 2017

    Do you the tools in path environment variables ? Just check the path. It cloud be a issue with path.



  • I guess the PATH is fine.
    Running "whereis otool" yield "/usr/bin/otool", which is in the PATH var.



  • Problem solved, thanks Dheerendra.
    My PATH environment variable wasn't correctly set after all.

    What I did to solve the problem:

    • sudo vim /etc/launchd.conf

    • Added the following line:
      setenv PATH /Library/Developer/CommandLineTools/usr/bin

    • Reboot.

    • Install.



  • Hello
    I also have a problem with installation the Qt 5.2.0
    I am using Mac OS X 10.9.1 and have Xcode downloaded today, and get this error:
    http://imgur.com/yxiKQlp

    I am new to Mac and don't know how to solve it even after long research in the web

    any help will be appreciated


Log in to reply