QtCreator 2.1. How to set QT source path.



  • I installed technology preview of Qt SDK 1.1 that ships with Qt 4.7.1 and QtCreator 2.1 RC (actually 2.0.95). This version of SDK unites mobile and desktop development, so it has quite different folder layout. Now Qt binaries and source files reside in different branches of folders.
    For example:
    QtSDK\Desktop\Qt\4.7.1\msvc2008
    QtSDK\QtSources\4.7.1

    I found that now Qt creator is not able to open cpp files of Qts' classes automatically. Earlier i was able to navigate easily from any Qts' header file to cpp file just by pressing standard key F4 ... How to fix it???



  • works fine for me though. I'm on win xp.

    Just chk if the correct shortcut is being shown in Tools->Options->Environment->Keyboard under CppTools section.



  • Key F4 setup is ok ... it works with my local project files. I think my problem is that in first turn I installed SDK without sources. When found that, I launched SDK maintenance program and installed sources in second turn. So I suspect that some things were not updated correctly in SDK installation. It seems like some SDK issue. I was trying to find some settings that Qt Creator uses for finding path to Qt sources but till now couldn't find any. Can somebody help me there?



  • you are actually right. it works with local projects and not Qt sources itself. I could reproduce on both win and linux. Resetting the shortcut key also didn't help. Maybe you should just log a bug for this against creator

    one more thing I notice is that this shortcut key is listed in red color in the options dialog



  • Thanks for reporting.

    For those interested, the issue can be tracked here: http://bugreports.qt.nokia.com/browse/QTCREATORBUG-3789


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.