Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

[SOLVED] One specific project is set to use another (Not installed) compiler.



  • @Qt Creator needs a compiler set up to build. Configure a compiler in the kit options.@

    Expands to:
    @02:10:45: Configuration is faulty. Check the Issues view for details.
    Error while building/deploying project Gui14 (kit: Desktop Qt 5.2.0 MSVC2010 32bit)
    When executing step 'Make'
    02:10:45: Elapsed time: 00:00.@

    I've not manually set MSVC2010 as the compiler to the best of my knowledge, and every other project builds fine. I don't currently have Visual Studio installed. (I usually have it for working with C# in Unity3D, but I'm trying the new version of MonoDevelop instead for now)

    How did this project (Which has successfully built before) suddenly get set to a different compiler, and how can I fix it?

    Running Windows 8.1, and following "this video":https://www.youtube.com/watch?v=TpkiVlOS3o4 after successfully following all the previous tutorials in that playlist in the last few hours.

    Please ask if you need any further information.



  • As expected I followed the tutorial again in a new project, and encountered no errors. But the old one still screws up.

    How do I make sure this doesn't happen again on something more serious, or undo it if it does occur?



  • Now two days later I've finally realized that it was staring me in the face. I missed it for two reasons: because I'm a text guy not an icon guy, and because I didn't connect the word "kit" to the word "compiler".

    To anyone else having this issue, the left-hand bar at the bottom has build, run and debug buttons, and above those there is a button to select the kit used. This allows quickly switching between kits. (compiler targets) This can also be accessed through Build > Open Build and Run Kit Selector


  • Lifetime Qt Champion

    Hi and welcome to devnet !

    Great you found out and thanks for sharing !

    Can you also update your thread title prepending [solved] ? So other forum users may know a solution has been found :)


Log in to reply