[Solved] My application cannot load proprely its dll



  • Hi everyone it's been more than 5 hours, and even before, that i am trying to find a solution to this error : this application failed to start because it could not find or load the qt platform plugin "windows".
    Available platforms plugins are : minimal, offscreen, windows.
    Reinstalling the application may fix the problem.

    i have uninstalled Qt from my machine to see if my application will work, since each time i send it to my friends, it make this error, and i really include all the necessary dll in the application folder, plus the folder platforms [and even inside plugins] with the qwindows.dll, qoffscreen and qminimal.dll, but it hasn't work. I ve googled my problem, and i found out about qt.con but the documentation seems not to be clear about it, nor the awnsers, is it me? i am really starting to give up here, please help me here is how my app folder looks like :
    the container folder is myTps
    platforms/
    icudt51.dll
    icuin51.dll
    icuuc51.dll
    libgcc_s_dw2-1.dll
    libstdc++-6.dll
    libinpthread-1.dll
    Qt5Core.dll
    Qt5Gui.dll
    Qt5Widgets.dll
    TP2Remake.exe

    Thank you if you help me ! i am actually on Windows7 32bit and i used Qt 5.2.0 to compile it, thanks again.



  • When I had this problem, I found a "qwindows.dll" in "C:\Qt\Qt5.1.1\5.1.1\msvc2010\plugins\platforms". Create a folder called "platforms" in your application directory and put the dll there. You may need to also create a folder named "accessible" and put qtaccessiblewidgets.dll there. It's in "C:\Qt\Qt5.1.1\5.1.1\msvc2010\plugins\accessible"


  • Moderators

    Hi, and welcome to the Qt Dev Net.

    qwindows.dll needs to be in the 'platforms' forlder. See http://stackoverflow.com/questions/19710879/visual-studio-qt5-plugins-not-working-on-release/19761382#19761382

    To check your deployment, you don't need to uninstall Qt. Just rename your Qt installation folder, and your computer will think that Qt is not installed :) Rename it back after you have finished checking.

    [quote author="greenaj" date="1388375019"]You may need to also create a folder named "accessible" and put qtaccessiblewidgets.dll there. It's in "C:\Qt\Qt5.1.1\5.1.1\msvc2010\plugins\accessible"[/quote]That's not always necessary. You only need qtaccessiblewidgets.dll if you are using the Accessibility classes.



  • Thanks for the fast reply, for the qwindows i've already put it in the platforms folder, but about the qtaccessiblewidgets, what's the point of adding it ? may i no why please ^^, thank you again ! i'm reinstalling Qt now !


  • Moderators

    Did you compile a Debug build or a Release build?



  • The application is actually done by Qt 5.1.0, then when i updated to 5.2.0, it gave me some strange error, then i recompile it but in it was a release build.
    I've add the qtaccessiblewidgets.dll in the accessible platform, but it doesn't work [i change the name of the Qt folder to make it like Qt uninstalled].


  • Moderators

    [quote]it gave me some strange error[/quote]When you encounter an issue, please provide the exact error message. It contains valuable information that makes it easier for others to understand your issue.

    Please delete your deployment folder, clean your build tree (Qt Creator: Build -> Clean All) and try again. If it still doesn't work, provide your folder structure again (like your original post) and all error messages you see.



  • I thank you very much JKSH and greenaj, sorry for no precising my post ^^", i ve just found the solution and it works now, the problem is that i used the Qt creator's dll and not the 5.2.0/mingw48_32/bin's dll wich are different, even if they share the same name, now that i copied the true dlls, it works, and that explains the "strange error" wich i m sorry about not mention it, it contains :
    "Le point d'entrée de procédure _78WinMainP11HINSTANCE__S0_PciRiR7QVectorIS1_E est introuvable dans la bibiolthéque des liens dynamiques Qt5Core.dll", it is in french ^^" but the content is that it doesn't found some directive inside the Qt5Core.dll, wich is incomplete because it belongs to Qt creator.
    Thank you again !


  • Moderators

    You're welcome. I'm glad to hear you've solved your problem :) Please edit your original post and add "[Solved]" to the title, so that people know that you've found a solution.

    The English version is "The procedure entry point 78WinMainP11HINSTANCE_S0_PciRiR7QVectorIS1_E could not be located in the dynamic link library Qt5Core.dll". This is a common error message when the wrong version of a DLL is used.



  • i did :). it's really awesome i have just registred in the forum yesterday! surely i have a lot to learn from everyone here !


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.