Qt 5.2.0 Msvc2012 Openssl linking problem



  • Hello, i'm trying to make a new version of qt to work with ssl. I'm using msvc2012 x86 compiler, i did the following configuration:

    @configure -static -debug-and-release -opensource -confirm-license -platform win
    32-msvc2012 -mp -qt-sql-sqlite -plugin-sql-mysql -I C:\QT\MYSQL\include -L C:\QT\MYSQL\lib -c++11 -no-opengl
    -nomake tests -nomake examples -no-crt -qt-zlib -qt-libpng -qt-libjpeg -no-crt -openssl-linked -I C:\OpenSSL-
    Win32\include -L C:\OpenSSL-Win32\lib\VC\static OPENSSL_LIBS="-llibeay32MTd -lssleay32MTd"@

    Then i done "nmake" and "nmake isntall" and the qt has built statically without any errors.

    But after when i tried to build my application i received a lot of"QSslSocket" link errors. "Here is the error log":http://pastebin.com/e3kKpa1P what can be wrong with the static linkage?

    Also i tried to link ssl without static qt, with default dynamic kit, i put

    @LIBS += -L$$PWD\openssl -llibeay32MTd -lssleay32MTd@
    and

    @INCLUDEPATH += $$PWD/openssl/include@

    it links successfuly but when i debug my app i get this errors when i try to load some https web page

    @QSslSocket: cannot call unresolved function SSLv3_client_method
    QSslSocket: cannot call unresolved function SSL_CTX_new
    QSslSocket: cannot call unresolved function SSL_library_init
    QSslSocket: cannot call unresolved function ERR_get_error
    QSslSocket: cannot call unresolved function ERR_error_string@

    The ssl libs im using are static, so i assume they should work. What am i doing wrong?

    [Pastebin log updated]


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.