[SOLVED] Qt 5.2 and iOS: Nothing to compile



  • I am currently trying to get a simple widget based "hello world" iOS application getting built with "Qt 5.2 for iOS". However, when using QtCreator to compile a freshly created test application with the iphonesimulator-clang kit it just says "there is nothing to be done for first", and no binary file is created. I have spent a few hours already to track this down, but can't figure out what I have configured wrong.

    I am using a MacBook Air with OS X 10.8.5, Qt 5.2.0, QtCreator 3.0.0 and XCode 5.0.2 (in case this matters). There is also Qt 4.8.5 installed on this machine, this this version is what I used for production purposes.

    Some more things to mention:

    • When running qmake from QtCreator it gives a warning "The version of XCode installed on this system is not recognized"
    • The iOS sample applications shipped with 5.2 do build and run correctly
    • When deleting the ".pro.user" file of such a shipped sample, which means that I need to reconfigure the project in QtCreator again afterwards (selecting the kit), the sample shows the same problems as my freshly created test app: qmake will warn about the XCode version and the make step will not do anything.

    Any hints are more than welcome!

    UPDATE: I have figured out that I need to add xcodebuild as an additional build step for some reason. This causes the files to get compiled. However, linking fails since it tries to link against the device libs (ios/lib/libQt5Gui_debug.a) instead of the simulator libs (ios/lib/libQt5Gui_simulator_debug.a). Any hint how I can fix this?



  • Updating to the latest XCode command line tools solved the problem!


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.