Important: Please read the Qt Code of Conduct -

Qt-creator help tab does not contain any information

  • I have compiled Qt-5.2 along with qt-creator 3.0.0 both from source.

    The problem I have come across is my qtcreator no longer has any documentation, both on the help tab as well as the inline help popups that would show things like parameter types and names. I have always compiled my environment from source before, and the help menus have always been there in the past versions. I am not sure what I might have done wrong for these to go missing.

    I have read elsewhere that Tools->Option->Help->Documentation is where I need to go to point my qtcreator to the help documents. The problem with this is I can not find where the documents are located. I have searched using both locate (with a fresh updatedb having been run) as well as the find command on my qtcreator install directory and my qt library install directory with no results.

  • Lifetime Qt Champion


    Did you build the documentation ?

  • I think that it is obvious that I didn't build it, albeit unintentionally. That was more or less what I meant about searching my build directories and coming up with nothing.

    When I ran my configure, I did not disable any building of any specific sub project, such as examples or tests for instance. I did search for something in the configure script related to documentation, but could not find anything. Aside from my destination install directory, I built the library from source with default settings.

    Is the source for the documentation included elsewhere, and I have somehow missed this?

  • Lifetime Qt Champion

    You only talked about install directories hence my question. If you have built Qt with all tools a simple

    @make docs@

    should give you the documentation.

    Part of the documentation is "in sources" and part in the doc folder.

  • That did the trick, thank you so much!

    For anyone running into this same issue, if you are multi-threading the build (for me, using 4 processors):

    For some reason, this failed miserably. Probably because make did not follow some build dependencies.

    make all -j 4

    What did work for me:

    make -j 4

    make docs

    sudo make install

    sudo make install_docs

    Issue is resolved. Please close this thread.

  • Lifetime Qt Champion

    You're welcome !

    I can't close it, however, you can mark it as solved by prepending [solved] to the thread title.

Log in to reply