[Solved] Multimedia component in QML Qt Mobility 1.1 requries OpenGL? Not included in Qt SDK TP 1.1 for Symbian^3?



  • Hi,

    Has anyone gotten an application using the multimedia component of the Qt Mobility 1.1 QML packages to compile for Symbian^3 under the Technology Preview SDK 1.1? It seems that as soon as I add
    @
    CONFIG += mobility
    MOBILITY += multimedia
    @ I get a linker error complaining about a missing OpenGL library as follows:
    @
    :-1: error: No rule to make target \QtSDK\Symbian\SDKs\Symbian1Qt471\epoc32\release\armv5\LIB\QtOpenGL.dso', needed by\QtSDK\Symbian\SDKs\Symbian1Qt471\epoc32\release\gcce\urel\MyApp.exe'. Stop.
    @

    I have read that this library needs to be self-compiled or obtained elsewhere but I haven't found any instructions as to how. Can someone help me out?

    Thanks!



  • Solved this myself again. The issue was that I accidentally compiled against Symbian^1 instead of ^3 and ^1 doesn't support OpenGL yet. This solves the case for me, however anyone targeting ^1 will still have this issue.
    See http://bugreports.qt.nokia.com/browse/QTMOBILITY-986


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.