Planned maintenance has been done but it did not solve the problem. So work will continue on this and a new time for trying updates will be announced asap.

Qt 5.2.0 nie chce budować.



  • Witam
    Wiele razy był tutaj poruszany temat Qt, które nie buduje kodu, ale zazwyczaj po zainstalowaniu SDK problem znika. U mnie ten error nadal wyskakuje. Czy po zainstalowaniu sdk trzeba coś zmieniać w qt? Używam wersji v7.1.
    Dodatkowo w narzędziach pisze: “Żaden kompilator nie może wygenerować kodu dla tej wersji Qt. Zdefiniuj jeden lub więcej komopilatorów.”


  • Moderators

    Z wyjątkiem pakietów MinGW, Qt nigdy nie dostarcza kompilatora razem z cały SDK. Musisz sam zainstalować pasujący kompilator, jeśli jeszcze go nie masz na swojej maszynie.



  • Jaki to powinien być kompilator?


  • Moderators

    Nie wiem na jakim jesteś systemie operacyjnym ani jaki pakiet Qt zainstalowałeś. Podam wszystko :)

    Na Macu: musisz mieć zainstaloweny Xcode wraz z Command Line Tools.

    Na Linuxie: zainstaluj g++ lub clang (jest dowolność: oba kompilatory są ze sobą zgodne).

    Na Windowsie: no tu jest pod górkę. Jeśli w nazwie SDK który zainstalowałeś jest "MinGW", to nie musisz nic więcej robić. Jeśli jest tam "MSVC2010" to musisz zainstalować MS Visual Studio 2010. Jeśli jest tam "MSVC2012", to musisz zainstalować MS Visual Studio 2012.



  • dzięki. Ten windows jest bezwzględny dla koderów...



  • A nie mogę po prostu pobrac mingw?


  • Moderators

    Możesz.


Log in to reply