Modifications not taken with QtCreator



  • This is a weird behaviour I have with QtCreator:

    * If I modify the ui within the designer the modifications are not taken in account, like nothing have been changed.
    

    Workaround : after tried clean/clean all/ compile/recompile the project/ quit QtCreator; it seems that the only possibility is to switch from the Symbian project to
    Desktop + recompiling and back to Symbian again.

    I use really often creator during all the day, and this just happened this morning

    As I tested it many times, I thought it was enough to create a bug :
    http://bugreports.qt.nokia.com/browse/QTCREATORBUG-3709



  • Hi, I think I have the same problem on Ubuntu 11.04/QtCreator.
    I have modified an .ui form, the changes written back to the filesystem.
    Have made clean/rebuild etc. but the running program always remains the same...
    Maybe some kind of cache?



  • I think I solved the problem.
    Something was wrong with the directory structure.
    I made the following changes:

    Created a folder "Naptar" for my project.

    Copied the former project folder "Naptar" with all the contents under the main "Naptar" folder.

    Deleted the "Naptar.pro.user" file.

    Opened the project file and set the new folders by simply clicking OK


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.